Turris Omnia 2020 (RTROM01-FCC) decreases ISP Bandwidth?

Hello together,

I am a new Omnia-user and my initial fascination has disappeared a little bit. :neutral_face:

In the past I have used a Fritz!Box 7360 that has delivered the full available modem speed to the PC client (28 Mbit/s in download, 6 Mbit/s in upload). However, the Omnia does only deliver 26.3 Mbit/s in download and 5.6 Mbit/s in upload, while latency times are very similar to the Fritz!Box. The Omnia is connected to a DrayTek Vigor 165 that should be sufficient as a pure modem, the PC is connected to the Omnia via cable over a Netgear switch.

DrayTek Vigor GUI claims a modem speed of 28 Mbit/s in download and 6 Mbit/s in upload what is exactly the same as Fritz!Box had. Therefore I fear that the Omnia is guitly for this decrease in bandwidth.

Well, that is not that tragically at all, but the fact that websites are loading extremely (!) slow is seriously annoying. It takes me up to 10 seconds to open google.com for example. That can’t be normal I think?

My ISP guaranteed bandwidth is 25 Mbit/s in download and 5 Mbit/s in upload. Like said before, with the Fritz!Box I never experienced such speed issues when loading websites, this issue arose with the Omnia.

Any ideas on what should be observed to figure out any potential issues?

Thank you very much in advance!

With best regards!

If your connection doesn’t have working IPv6 and the extra latency comes from DNS, it could be broken detection of non-working IPv6 slowing it down. If that’s so, it can be explicitly disabled (though I suspect there’s no GUI way, i.e. I’m not sure if just disabling it in WAN tab is sufficient).

EDIT: in any case, the idea above has no relation to bandwidth. I don’t know the modem cases well, but people commonly use Omnias with way higher bandwidths (hundreds of Mbps).

1 Like

(Still just DNS, assuming that’s what’s causing the lag. Best check by trying utilities like nslookup or dig.)

Actually I forgot that the default DNS mode is forwarding (I think) and Fritz!Box could serve DNS with some issues. If that is the problem, there are a few alternatives that could be tried:

  1. uncheck DNS forwarding (Foris UI, DNS tab) and thus avoid using Fritz!Box DNS; but the note with IPv6 may apply then :slight_smile:
  2. change DNS forwarding to some provider that has low latency from your location (and you need to trust them with privacy) and thus avoid using Fritz!Box DNS
  3. update Fritz!Box firmware; apparently they’ve fixed the issue that was observed: https://gitlab.nic.cz/knot/knot-resolver/-/issues/551#note_156222
1 Like

The problem is solved! :grinning: Issue was:

Previously I have changed the IP-address to However, the IP of DHCP and DNS-server did not get changed automatically. Therefore DHCP server worked on its new IP while DNS server remained at the old

I guess this is a bug? :stuck_out_tongue_winking_eye:

I am guessing here, but modems like the fritzbox or the vigor tend to report the negotiated gross rate over the DSL link, but a secondary router will not know the sync rate at all. With the typical overhead on dsl llinks a gross sync of 28 allows a mesurable goodput with typical online speedtests like the omnia’s netmetr, or speedtest.net of 26.3, and a sync of 6 allows at best a goodput of 5.6.

IMHO these number imply that the difference might really be in the reportingbof gross sync rate (Brutto) versus reportingbof measured net goodput (Netto). An essy way to test is atting both routers again and simply run an online speedtest from a computer connected to the router.
Hope that helps.

1 Like

Ooops, that means the servers are in two different /24s, that is likely to cause issues… When I faced a similar situation and wanted to move my omnia’s prefix from to, I just changed the field named “Router IP address” under saved, and that automatically changed all server addresses as well.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.