Turris Omina: intermittent packet drops

Hello everyone,

I am not sure if a problem like this fits into the scope of this forum but I ran into a very interesting issue for which I do not have a good explanation (at least not yet).

In short, after setting up a new Turris Omnia, I noticed that the DNS resolution tends to work “after a few tries”. I was not able to get some more detailed logs but it felt as if it took a couple tries to the DNS cache to get “hot” and afterwards it worked relatively well.

To investigate it further, I tried ping on google.com as well as, and was met with the following screen:

That suggests as if each 10 seconds something specific happened that made the ping take seconds instead of miliseconds, which would then be the case for the subsequent 10-ish requests.

All in all the ping statistics look quite bad – there seems to be roughly 70% packet loss:

2187 packets transmitted, 645 received, +3 errors, 70.5075% packet loss, time 2226049ms
rtt min/avg/max/mdev = 22.611/306.605/3075.038/663.915 ms, pipe 4

Note that the test has been executed from a WiFi connection but the WiFi-router connection should not be a problem: a subsequent test has shown 0% packet loss when pinging just the router address. Hence, it seems the problem is between the router and the internet/my ISP.

Did you run into something similar by any chance? Would you happen to have some advice so as to what I could try to do to mitigate this? Is there a chance this is caused by my ISP/connection beyond the router itself? Although I don’t really see why that would be the case, do you think this could be a hardware issue?


Firmware Version: TurrisOS 4.0.1 80076f9 / LuCI branch (git-19.281.84184-0b4eebd)
Kernel Version: 4.14.148

I use forwarding to CZ.NIC with DNSSEC turned on.

What’s worse, several of them don’t return at all, as if the connection was cut for a few seconds. Of course in such moments DNS will also have issues, but DNS won’t be the cause.

I’d first try to find where this packet loss happens. For example, simply use the mtr tool instead of ping.

This version is not supported anymore and deprecated. You should update your router to the last version, which is currently Turris OS 5.1.10.

Thanks, that makes a ton of sense (and I am pretty mad at myself for not starting with it)!

Here is what the output of mtr looks like:

I should note that the two _gateways reflect the specifics of this particular setup: the first one is the Turris Omnia router, the second one the ISP-provided router.

The reported 76% packet loss, however, is very strange – in particular because when trying the same experiment with a cheap router I’ve been using previously (TL-WR1042ND), the report looked as follows:

Can you think of anything I may be doing wrong in here?

Thanks again!

Thank you for the note – I did not notice that.

What do you think would be the best way of doing so on this particular version? It doesn’t seem like using the updater would be an option (I at least could not find it in there but I may have easily missed it).


Why do you think that? The update must works from this version as this is the version from the factory.
Open the Foris web interface located on the IP address on your router and then go to the Updater tab and click on the Save changes button. You don’t need to make any changes there, and then it will immediately run the Updater in the background. In a short while, you should receive a notification about the update.

Thanks @Pepe, that indeed makes sense.

Sadly, I don’t think this approach will work with 70+% packet loss, so I’ll see if I can figure that out first.

there were different problems in old versions of TOS, some related to system uptime.
Have you tried rebooting?

Thank you everyone for your suggestions. In the end, the issue turned out to be extremely straightforward: the network setup have had two gateways on the same network, which shared the same IP address ( What I experienced was hence to be expected…

After figuring this out and getting Turris Omnia updated to the latest stable version, everything works rather nicely.

Thanks again for all your help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.