Turris MOX: No signs of life from SDIO wifi card

Hey everyone.
I just got hands on a used turris mox and can’t wait to put it to use as my main router.
Unfortunately i ran into a problem setting up wifi on it.
I have two wifi boards, one SDIO (?) Board on the Mox A and another Board on Mox B. Config (The wi-fi board on mox b might be wrong, it only supports AC wifi): Turris MOX Configurator
Unfortunately i can get no signs of life from the wifi module on the Mox A. It does not show up in the gui and “ip a” does not show it (only wlan0, not wlan1)
I also tried reseating the module and upgrading and resetting the router.
Does anyone happen to have recommendations how to further proceed debugging? I’ve read somewhere that there is some hardware issue with the first MOXes produced and this one supposedly dates back to the crowdfounding campaing. But i also found no real info on that.

Thank you already for reading (and potentially answering)

What is the output from lspci?
Can you take a picture from the card in MOX B?
Which Turris OS version is installed?

The SDIO cards are very special, have limited functionality and thus are discontinued - but are still suitable for some (rare) use cases (e.g. for connecting IoT- or guest-devices that are directly connected to TOR-network or alike).
I strongly dissuade from using it for normal productive SSIDs.

Hey, the requested facts:
My mox is running the latest firmware (at least when i checked a few hours back): TurrisOS 6.4.4, Turris Mox

00:00.0 PCI bridge: Marvell Technology Group Ltd. 88F3700 [Armada 3700 Family] ARM SoC
01:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

The reason i wanted touse the SDIO card was that (at least to my understanding) the card in the mox b is not able to operate on 2.4Ghz and 5Ghz simultaneously and i saw examples using the SDIO card for 2.4ghz wifi (for legacy devices, microcontrollers and potentially devices out of range of 5Ghz).
If usage of the SDIO card is highly deprecated what is the suggested alternative? Is there a trick to get the other wifi card to handle both frequencies or would i need to replace it with the newer wifi6 card?

Thank you already

Is the SDIO-card connected to antennas (cannot be seen on your picture)?
Is the card correctly connected to the slot (gently press down the card towards the board)?
Did you delete /etc/config/wifi and afterwards cold-boot your MOX?

First: Sdio legacy - Turris Documentation
You will get only WPA2, WPA2 enterprise does not work, have a limited amount of SSIDs and a maximum of 8 connected clients contemporaneously. In addition to that there is a maximum signal strength of 16dBi, if I remember correctly. And there will be no further development for closing bugs.
And you have to do special configuration to get a SSID it to work (sorry, cannot find it ATM, it is somewhere written in Turris docs, but you can also do some research here on the forum).

Good approach is to replace WLE900VX-card from slot B by WiFi 6 DBDC as you mentioned. And for sure take out SDIO to save energy :wink:

I had the same problem some time ago. Following you’l find advice from support:
“Anyway, the SDIO card fix apparently didn’t quite make it into the Turris OS release. So you’ll need to set up WPA 2 encryption only (can be set up in reForis) and enable legacy 802.11b speeds (you need to set this in LuCI under “Network - Wireless” and select the modification of that SDIO card from Marvell).”
Hope it helps.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.