Turris MOX Cloud - Setup?

I got my Turris MOX Cloud some days ago. As far as I understood it from the campaign the MOX cloud should have been delivered with pre-installed Nextcloud, but I’m unable to find it anywhere in the system settings (and I’ve been no Linux user so far). Now I just found that link: https://doc.turris.cz/doc/en/howto/nextcloud

But this doesn’t really help and just lets me guess I have to install Nextcloud by myself.
It was said I could use RAID with the MOX, but also I have no idea how to set this up.

Hope someone from Turris team might help…


When you receive the router for the first time, you will need to finish Guide which will help you with the basic configuration of your router in administration interface Foris. You can find it on, but it can be changed in Guide and/or later if you change your mind and want to use different local router IP address in the LAN tab.

When you finished guide you will need to install Nextcloud manually. Go to Updater tab, check there Nextcloud, press button Save and update. You will need to plug HDD(s), flash drives to your router. Format it and set it with Storage tab. Once you do that and reboot your router, then you will see more options in Storage tab for Nextcloud, where you will fill credentials to use with Nextcloud and then you will see Nextcloud web app (= landing page) after accessing the local IP address of your router.

May I know, if you are able to find where you get understanding that it should be pre-installed?

1 Like

I already thought theRe would be pre-installed Nextcloud when I backed the project, and I remember that I asked in the comments which version of Nextcloud would be on the MOX in delivery state. I could got this wrong, but there was never and nowhere said that the MOX Cloud (what already suggest an out of the box use) needs additional install processes to get Nextcloud on the MOX.

But I was very unsure after getting my Mox if there went something wrong so I decided to ask. I’m already using Nextcloud on a hosted webspace, so it won’t be a problem for me to really finish the setup (at last with your hints), but I was somehow disappointed getting the Mox with no further information how to continue.

So thanks for the response; I’ll try it this evening to get the mox cloud running as it should be. IP changes and implementation into my local network hadn’t been a problem and worked well (after I realised that I first had to establish a direct connection between Mox and a PC; tried it first from my smartphone…).

@Cryxthere is a small video help for you :slight_smile:

So I tried it now, also watched the video linked below (which btw doesn’t run using Microsoft Edge…), but there is no Nextcloud package I could choose in the updater tab. So what’s wrong?

Which version of Foris do you have? You should have 100.2.

I have 99.9. The MOX says its up to date…

Hm, there seemed something to be wrong. Tried some other settings, and now there was an update, new version is 100.2. Lets continue… Maybe it will work now.

Edit: And it does…

Had no time to test it within the last days, but now - but it doesn’t work. When I connect a HDD to my mox every click on storage setup ends with the following error:

An unexpected error has occurred

We are sorry, but your request raised an unexpected error. More information about this error may be found below.

If you are willing to help us with fixing of the problem, download the following error protocol and send it to us with a short description of the steps that led to the error to our email address tech.support@turris.cz (the protocol contains only a copy of the following informations).

Při zpracování požadavku došlo k chybě

Omlouváme se, ale během zpracování Vašeho požadavku došlo k nečekané chybě. Detailní informace naleznete níže.

Pokud nám chcete pomoci s odstraněním chyby, stáhněte následující protokol o chybě a zašlete nám jej s krátkým popisem okolností vzniku chyby na adresu tech.support@turris.cz (protokol obsahuje pouze kopii informací uvedených na této stránce).


Stack trace

Traceback (most recent call last): File “/reporting.py”, line 93, in call File “/backend_data.py”, line 86, in call File “/bottle_i18n.py”, line 68, in call File “/bottle.py”, line 979, in call File “/bottle.py”, line 954, in wsgi File “/bottle.py”, line 862, in _handle File “/bottle.py”, line 682, in mountpoint_wrapper File “/bottle.py”, line 979, in call File “/bottle.py”, line 954, in wsgi File “/bottle.py”, line 862, in _handle File “/bottle.py”, line 1740, in wrapper File “/init.py”, line 79, in wrapper File “/init.py”, line 146, in config_page_get File “/init.py”, line 41, in render File “/backend.py”, line 102, in perform File “/backend.py”, line 85, in perform File “/mqtt.py”, line 361, in send TimeoutError


{‘CONTENT_LENGTH’: ‘0’, ‘DOCUMENT_ROOT’: ‘/www’, ‘GATEWAY_INTERFACE’: ‘CGI/1.1’, ‘HTTP_ACCEPT’: ‘text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8’, ‘HTTP_ACCEPT_ENCODING’: ‘gzip, deflate’, ‘HTTP_ACCEPT_LANGUAGE’: ‘de-DE,de;q=0.8,en-IE;q=0.5,en;q=0.3’, ‘HTTP_CONNECTION’: ‘Keep-Alive’, ‘HTTP_COOKIE’: ‘foris.session=92fe39548c339f27ac252f1a84d91993; ’ ‘foris.ws.session=c50b4716b2aac0700439a6615893beea’, ‘HTTP_DNT’: ‘1’, ‘HTTP_HOST’: ‘’, ‘HTTP_REFERER’: ‘’, ‘HTTP_UPGRADE_INSECURE_REQUESTS’: ‘1’, ‘HTTP_USER_AGENT’: ‘Mozilla/5.0 (Windows NT 10.0; Win64; x64) ’ ‘AppleWebKit/537.36 (KHTML, like Gecko) ’ ‘Chrome/64.0.3282.140 Safari/537.36 Edge/18.17763’, ‘PATH_INFO’: ‘/main/storage/’, ‘PATH_TRANSLATED’: ‘/www/main/storage/’, ‘QUERY_STRING’: ‘’, ‘REDIRECT_STATUS’: ‘200’, ‘REMOTE_ADDR’: ‘’, ‘REMOTE_PORT’: ‘61143’, ‘REQUEST_METHOD’: ‘GET’, ‘REQUEST_SCHEME’: ‘http’, ‘REQUEST_URI’: ‘/foris/config/main/storage/’, ‘SCRIPT_FILENAME’: ‘/www/foris/config’, ‘SCRIPT_NAME’: ‘/foris/config’, ‘SERVER_ADDR’: ‘’, ‘SERVER_NAME’: ‘’, ‘SERVER_PORT’: ‘80’, ‘SERVER_PROTOCOL’: ‘HTTP/1.1’, ‘SERVER_SOFTWARE’: ‘lighttpd/1.4.50’, ‘bottle.app’: <bottle.Bottle object at 0x3057b418>, ‘bottle.raw_path’: ‘/storage/’, ‘bottle.request’: <LocalRequest: GET>, ‘bottle.request.urlparts’: SplitResult(scheme=‘http’, netloc=‘’, path=’/foris/config/main/storage/’, query=’’, fragment=’’), ‘bottle.route’: <GET ‘/<page_name:re:.+>/’ <function config_page_get at 0x3052f018>>, ‘foris.backend’: MqttSender(‘localhost:11883’), ‘foris.language’: ‘de’, ‘foris.session’: <foris.middleware.sessions.SessionForisProxy object at 0x307184d8>, ‘foris.session.data’: {‘csrf_token’: ‘WgQ9nfrOm9OModpz1GKeYX3qdhy1gfFA’, ‘user_authenticated’: True}, ‘foris.session.id’: ‘92fe39548c339f27ac252f1a84d91993’, ‘foris.version’: ‘100.2’, ‘route.handle’: <GET ‘/<page_name:re:.+>/’ <function config_page_get at 0x3052f018>>, ‘route.url_args’: {‘page_name’: ‘storage’}, ‘wsgi.errors’: <flup.server.fcgi_base.OutputStream object at 0x3070ae18>, ‘wsgi.input’: <flup.server.fcgi_base.InputStream object at 0x30744c98>, ‘wsgi.multiprocess’: False, ‘wsgi.multithread’: True, ‘wsgi.run_once’: False, ‘wsgi.url_scheme’: ‘http’, ‘wsgi.version’: (1, 0)}