Turris firmwae flash failed. Bootes into tftp mode


#1

I tried to flash openwrt. Booting into Medkit fom USB worked fine.

sysupgrade killed the terminal session and probably failed.

Now, Turris boots into some tftp-mode on WAN port. It gets an IP address via DHCP and requests AC1203B9.img using tftp. Tried to serve all kind of files, but none made a difference beyond that point.

Any advice?
Thanks.


#2

To what extend? To get TOS back or to keep tinkering with OpenWRT?


#3

While I prefer to flash OpenWRT, TOS is fine as well. As long as I do not need to go out and buy a seial cable.


#4

There are some sources at OpenWRT and related wiki/forum and a few snippets in this forum about recovery a/o installation of OpenWRT on the TO.

As for TOS recovery there is 4 LED https://doc.turris.cz/doc/en/howto/omnia_factory_reset which can used either for vanilla TOS or using exported snapshots of a previous TOS installation.


#5

The 4 LED reset or any other reset does not have an impact on the behaviour of the box.

Upon reset or boot, the attached USB stick is ignored and the box very quickly activates WAN port, gets an IP address and requests AC1203B9.img by tftp.

I tied to send various image files such es medkit, medkit’s zImage and others. The box does seem to be doing anything useful with those files.


#6

Assuming that there is no fault of the usb drive/format it seems that the boot sequence might have been set by the previous events from the OpenWRT activity, e.g. the boot environment variables been altered.

In that case it would likely require a reset of the environment variables with env default -a and then saveenv which though requires a UART serial TTL…

Alternatively you may also seek help at the OpenWRT forum about recovering from the current state as this forum might be the lesser knowledgeable about OpenWRT’s intricacies.


#7

Thanks fpr the support an help.

Got a serial cable. Had to fix bootenv. And was able to properly flash a new image.