Turris does not resolve avherald.com

Hey, I have following problem. My turris does not resolve avherald.com.
Everything else works. How can I find out what the problem is? The site itself is up.

Any ideas?

Thx in advance



[root@turris]~# nslookup avherald.com
Server: (null)
Address 1: ::1
Address 2: localhost

Name: avherald.com
Address 1: nomis-ip06.nomissoft.com

Have you done any configuration changes in Turris that might relate to DNS or DHCP?

I’ve assigned the router a static IP (the turris is behind my ISPs own router at the moment, but its in a DMZ and on the ISPs router I can get to avherald.com) and added additional DNS servers on the Foris interface. The ones I usually use. I also removed them and put everything to standard. I also had the adblocker packet installed, which wasn’t working anyway because of the resolver configuration in the turris. I also deactivated that. Rebooted.

But for some reason he just does not resolve that domain. The question where do I have to look why he cannot resolve that single domain.


I’d been fighting a similar situation with youtube.com - DNSMasq insisted on resolving it to In my case, Adblock does appear to start and run, but the stats section never shows anything is ever blocked (even going thru the guide listed on this forum), so I just ended up building out a hosts file to clean up the worst offenders. All of that worked just fine, but youtube just never resolved properly. I finally got around it by editing both the /etc/dnsmasq.conf and /etc/dnsmasq.config (Though adding once may have been sufficient, someone with more experience could confirm) with this line:


(Just took one of the multitude of YT IP Addresses geo-close to me) and, at least in my case, youtube now works on my cell phone and the Roku box sans ads.

Hope it helps.

It might be a rate limit on the DNS servers you are using. I had the same issue here with different places, and had to change the upstream servers I used.

Thx for all the ideas. Turned out, the IP I had in the recent weeks, was blocked by the webmaster of this site, as there was a supposed attack from this IP to the website, some month ago.

Now its works again, however it is a bit strange, that it worked, while using the router if the ISP and not when using the turris omnia. Oo

Maybe I should switch the ISP router as it might be infected.