Turris as access point with vlans

Hey ppl!

I wanted to configure my turris as access point of my networks. Unfortunatelly this is not as trivial as I though to split the networks in vlan since the turris os 4 swconfig is not supported. I saw many threads here but none of them was really helpful. So I have configuration as following:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals ‘globals’
option ula_prefix ‘fdb4:69e3:faac::/48’

config interface ‘lan’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.248’
option ipaddr ‘192.168.0.2’
option gateway ‘192.168.0.1’
option dns ‘192.168.0.1’
option ifname ‘eth0.666’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option vid ‘666’
option ports ‘3t 5t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘3t 5t’
option vid ‘20’

config switch_vlan
option device ‘switch0’
option vlan ‘3’
option ports ‘3t 5t’
option vid ‘30’

config switch_vlan
option device ‘switch0’
option vlan ‘4’
option ports ‘3t 5t’
option vid ‘40’

config interface ‘LOCAL_WLAN’
option type ‘bridge’
option proto ‘static’
option ifname ‘eth0.20’
option ipaddr ‘192.168.20.210’
option netmask ‘255.255.255.0’
option gateway ‘192.168.20.200’

config interface ‘GUEST_WLAN’
option type ‘bridge’
option proto ‘static’
option ifname ‘eth0.30’
option ipaddr ‘192.168.30.210’
option netmask ‘255.255.255.0’
option gateway ‘192.168.30.200’
option dns ‘192.168.30.200’

config interface ‘SMART_HOME’
option type ‘bridge’
option proto ‘static’
option ifname ‘eth0.40’
option ipaddr ‘192.168.40.210’
option netmask ‘255.255.255.0’
option gateway ‘192.168.40.200’

config switch_vlan
option device ‘switch0’
option vlan ‘6’
option ports ‘3 5’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘7’
option ports ‘3t 5t’
option vid ‘100’

config interface ‘DMZ’
option type ‘bridge’
option proto ‘static’
option ifname ‘eth0.100’
option ipaddr ‘192.168.100.2’
option netmask ‘255.255.255.0’
option gateway ‘192.168.100.1’

Since I am not very familiar with DSA switches it is a little bit complicated to me, how to create these vlans… This is not very well documented. I am a little bit angry, because this thing was not cheap and if I will not be able to configure it on turris os 5 I have to buy new router…

Buy another router… or simply read the docs if you want to use Omnia:

EDIT:
In general the rule with DSA is you use lan4 for untagged (access) port and lan4.2 for tagged port. Then you assign bridges as normal. But there is no gui in luci yet and there is some bug (https://gitlab.nic.cz/turris/os/build/-/issues/165) related to DSA switch that for example prevents me from using it the way I want. The fix is only here: OpenWrt 21.02 RC1 is in HBD branch

With turris os version 4.x and up you dont have to and you shouldnt configure switch part in your network config. Just treat each port as separate interface.