Turris 5.x, LXC automatic startup failing

I just did the experimental upgrade from TurrisOS 3.x to 5.x (in my case 5.1) and while most things still work very well (thank you developers) an LXC container I use no longer automatically starts after rebooting the Omnia. I’ve used them for years with TurrisOS 3.x following the official Turris LXC documentation and before the upgrade, automatic start always worked as expected.

I created this one using the LuCI GUI instead of the CLI, which is the only difference from before the upgrade.

root@turris:~# lxc-ls && cat /etc/config/lxc-auto
config container
  option name pihole
  option timeout 60

The container appears in LuCI under Services > LXC Containers > Available Containers and I can manually start it after a reboot without errors. However it will no longer automatically start after a router restart, which is a new problem after the TurrisOS 3.x to 5.x upgrade.

Anyone have further advice, or troubleshooting tips please?

One minute after posting I had a look in LuCI System > Startup, and discovered the initscript lxc-auto was disabled by default. I enabled it, restarted the Omnia, and problem solved. If you have the same issue I hope this helps.

1 Like