Turris 3.11.3 and syslog-ng

Hi all,

I was travelling and upgraded to 3.11.3 just last week. Now I discovered that the syslog-ng doesn’t work at all. I found discussion about missing folder in /etc for RC. This is not a problem - the folder is there however syslog-ng process is not running. When I tried to start it through /etc/init.d/syslog-ng start (or restart) there is no error displayed but the logging doesn’t work.

It’s difficult to provide more details without logs …

Any suggestions?



Did you make any changes to /etc/syslog-ng.conf? First, I suggest to do what was said here:

I tried it but no luck - I renamed /etc/syslog-ng.conf-opkg to /etc/syslog-ng.conf and restarted syslog-ng but no change - the process is still not running.

When I commented out the included files it works. I have there configuration which puts the error messages in files on SSD disk. Has the configuration syntax changed?

I am not sure what is your exact syntax for including another config file but now you need to use

@include another/file.conf

instead of simple include . At least this solve it for me.
Or as @sladky pointed out in his message in Czech, there might me also issue with date specification

He suggested to replace ${ISODATE} with this complicated date/time definition: ${R_YEAR}-${R_MONTH}-${R_DAY} ${R_HOUR}:${R_MIN}:${R_SEC}

${ISODATE} seems to work for me. I found the problem - either I renamed the sources when I setup syslog-ng ~2 years ago or they were changed in the syslog-ng.conf file - so the sources I referenced in the individual *.conf files were not found and therefore syslog-ng didn’t start.