Trying to install lighttpd-mod-accesslog, getting no joy

Hi all,

I’m running v5.1.8, building a medkit on command line (Ubuntu 20.04). That’s working fine (now).

So I figured I’d play with fire and try to add a package to the medkit build. I’d like to add logging to lighttpd (at least for development), so I figured I’d quickly be able to just do a

cd build
make menuconfig (and then enable it - this went fine - it’s got a Y in my .config)
./scripts/feeds update -a
./scripts/feeds install -p turrispackages lighttpd-mod-accesslog

and that would put a copy in my build/package directory. But no luck - the command runs, but doesn’t show any files being installed. I know what that means - it’s not working:)

So, I tried this:

build/scripts/feeds install -p packages lighttpd-mod-accesslog, because openwrt package list also lists lighttpd-mod-accesslog as available, but again, no joy. Nothing gets installed into build/package/feeds/*.

I tried installing with the -f, using both turrispackages and packages feeds, no luck.
I tried cleaning and then installing, no luck.
I tried uninstalling and then installing, no luck.

Does anyone have any suggestions? Both turrispackages and packages list lighttpd-mod-accesslog as available… but I can’t install it from either…

$ ./scripts/feeds list -r turrispackages | grep lighttpd-mod-accesslog
lighttpd-mod-accesslog Access logging module

$ ./scripts/feeds list -r packages | grep lighttpd-mod-accesslog
lighttpd-mod-accesslog Access logging module

As a side note, running ‘opkg update; opkg install lighttpd-mod-accesslog’ on the MOX itself works fine.