Transmit power 2,4GHz-wifi-network

Hi @all,

I just configured my wifi-network and had to learn, that the 2,4GHz-card seems to offer a transmit power of only 79mW (19dBm). Thats not enough power to cover a whole house.
Does the card really offers no more transmit power or are there any software-restrictions? Do I have to buy a other wifi-card? If so, which one and are there any guides installing/configuring the software to get them working?

Kind regards,

1 Like

There are 2 things to keep in mind.

  1. The 2.4 GHz offers up to MAX 16 dBm

Output (Per Chain) 16dBm

  • By the country’s law there are limits on to how much the transmit-power may be. If you go over that, that is illegal AND you will mess up the WiFi-network of your neighbors.

To cover most of your house you need to keep certain things in mind.

  • Put the router somewhere in the middle of your house. Also a bit high.

  • If you have a house with multiple floors and the WiFi doesn’t reach everywhere, then you will be forced to use a cable OR buy a WiFi-repeater/extender.

If you do plan to use the second point (WiFi-repeater/extender), i would advice to just go with the 5 GHz network instead…IF all your devices (laptop/smartphone/tablet etc) support 5 GHz network off course. Also my advice would be to use a cable between the Omnia and the WiFi-extender/repeater.

You might want to check this thread Poor 5GHz coverage [FIXED, old phone at fault] (especially fixing the antennas, cable check …)

Yeah, I see… the point is that the Omnia in the very same position as the old COTS router performs worse and it looks like I’m not the only one to experience that (Thanks Max for the other thread link)! :frowning:

I guess you are talking about 2.4 GHz wifi-network. I have said it previously and i will say it again. IF it is possible, try to make the step towards the 5GHz network. EVERYHING and everyone is using 2.4 GHz now a days. My Omnia is in the other room and i am connected with 5 GHz network.

I am getting exactly the amount that my laptop can get (433 Mbit). It sometimes fluctuates between 350-433 Mbit… Play a bit with the antennas and also play a bit with the position of the router.

Yes, I’m using 5GHz, but the 2.4GHz has better penetration and in some rooms it was the only band usable.
Now with Omnia also the 2.4GHz band doesn’t work there.
In general both bands seems to be weaker than the previous AP with internal antennas.
FYI, I tightened as much as possible the antenna, connectors and verified the internal cabling, but no change.
I also checked the signal strength with a WiFi Analyzer app on android and I found that the 2.4GHz signal from time to time drops to zero (all the other 2.4GHz signals from the neighbors fluctuates but never drops to zero).

What about other networks around? Do you have many 5 GHz around or especially 2.4 GHz around…and broadcasting on the same channel?

Actually, I don’t see any 5GHz around at least in ch36 neighbors and also the 2.4GHz is on ch11 while all the others I can see are on 6 or below.
Today I was playing a bit with the antennas position but no real changes, actually all the others positions worst than the upright position for all of three. Then, suddendly, the 5GHz band started to drop every few seconds and this was going on until I reloaded the router! :unamused:
It looks like that there are some serious issues with the firmware, maybe it is not by chance that they have enabled the debug log by default…

Could you give me the output of the following commands. btw, to be sure of it…you do have the Turris Omnia not those other ones right?

iw reg get



cat /etc/config/wireless

Do hide/remove your SSID and password in the “wireless” config file.

Sry, but 16dBm (39mW) or 19dBm (79mW) is (far) below the limit, that’s stated by law (100mW or 20dBm for the most contries of the world according to wikipedia).
Thanks for your advices, but I bought that device to be the only one in my household (concrete ceilings/walls etc, 3 floors) - I wanted to replace a Linksys WRT1900AC that is really setting standards in 2,4GHz coverage as I had to learn… :frowning:
I don’t talk about 5GHz and neighboors don’t matter as they are several dozen meters away (in any direction) and signal strength is blocked by many trees. If you want to have fast connections you have to put one 5GHz-ap on every floor or one 16GHz-ap in every room (802.11ad when it is publicly available).
But I want to have one 2,4GHz-ap, because that is possible.

I’m simply dissapointed of that poor possibilities.

1 Like

I just want to weigh in here that I’m also quite disappointed at 2.4Ghz wifi performance. I’ve also replaced my cheapo ISP-supplied router/ap, only to find out the Turris performs even worse :(. I know there’re options of moving to 5Ghz or placing the box at a different locations but those arguments are beside the point. The Turris should at least perform on par with a ~ 50 euro run of the mill device. It really doesn’t right now. Hopefully driver improvements or tweaking transmit power will give us something to look forward to?

Will we benefit from adding two dedicated 2.4Ghz antennas? I guess I can throw some more money at it but not if I don’t get anything out of it.

1 Like

You can absolutely max out coverage by using antennas like this here: (can be easily build on your own, if the don’t deliver to your country).
edit: but the missing 20mW (or even more) will cost you coverage anyway…
edit2: I think we should replace the WLAN-module by a simply stronger one. 3x3, 450mbit and at least 20dBm output (better maxed out to 30dBm - anyone should decide on his own how to handle this, on big properties you won’t ever get near neighbours…).

1 Like

Well in the past i did not keep my self too busy about whole tx-power issue, because i did not pay any attention to it.

When the Omnia arrived, i was abit surprised to see a 16 dBm in it just like you said. I am not using 2.4 GHz as my wifi-network, but instead the 5 GHz. I have replaced the 2.4 GHz with a better one, that does support at least 20 dBm.

Well lets spread the possibilities and think with me.

If you have and keep the 2.4 GHz just because of the range, you can expect that within a few years that will just not do. It might get far, but the speed doesn’t give it what it should get. I used 2.4 GHz with about 2-3 walls between it and i got around 60 Mbit, which i would usually could get a max of 150 Mbit. I experienced a lot of trouble when wanting to stream movies that were around 6 GB (x265, 1080p).(more needed to be buffered to play it smoothly).

If you have three floors. You put the Omnia somewhere in the middle of the groundfloor. On the first floor a extender and also on the other floors extenders. Between the Omnia and the extenders you have cables to have a steady connection.

This way you would be having a good 5 GHz WiFi connection with about 0% interference and a good speed on the devices. IF those devices all support 5 GHz off course.

If this doesn’t work for you, well there are still other possibilities, but i refer you to @Etz :joy:

@Big_boss: here is my config:

root@turris:~# iw reg get
country CZ: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS
        (5470 - 5725 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

root@turris:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr D8:58:D7:00:35:E8
          inet addr:  Bcast:  Mask:
          inet6 addr: fdca:d8c1:a6c4::1/60 Scope:Global
          inet6 addr: fe80::da58:d7ff:fe00:35e8/64 Scope:Link
          RX packets:1897231 errors:0 dropped:30 overruns:0 frame:0
          TX packets:3539522 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:173771963 (165.7 MiB)  TX bytes:2579978152 (2.4 GiB)

eth0      Link encap:Ethernet  HWaddr D8:58:D7:00:35:E8
          RX packets:1781147 errors:0 dropped:1722 overruns:0 frame:0
          TX packets:3392142 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:184744819 (176.1 MiB)  TX bytes:2429088006 (2.2 GiB)

eth1      Link encap:Ethernet  HWaddr D8:58:D7:00:35:E9
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::da58:d7ff:fe00:35e9/64 Scope:Link
          RX packets:3526090 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1878528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:2603910338 (2.4 GiB)  TX bytes:185102167 (176.5 MiB)

eth2      Link encap:Ethernet  HWaddr D8:58:D7:00:35:EA
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48790 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:0 (0.0 B)  TX bytes:29673896 (28.2 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:5476 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5476 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:490611 (479.1 KiB)  TX bytes:490611 (479.1 KiB)

pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:x.x.x.x  P-t-P:  Mask:
          RX packets:12223 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10293 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:11024052 (10.5 MiB)  TX bytes:2570853 (2.4 MiB)

wlan1     Link encap:Ethernet  HWaddr 04:F0:21:23:23:D8
          inet6 addr: fe80::6f0:21ff:fe23:23d8/64 Scope:Link
          RX packets:15433 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61796 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2014036 (1.9 MiB)  TX bytes:37545637 (35.8 MiB)

root@turris:~# iwconfig
gre0      no wireless extensions.

pppoe-wan  no wireless extensions.

wlan0     IEEE 802.11  Mode:Master  Tx-Power=23 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

sit0      no wireless extensions.

gretap0   no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

eth2      no wireless extensions.

ip6tnl0   no wireless extensions.

wlan1     IEEE 802.11  Mode:Master  Tx-Power=16 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off

br-lan    no wireless extensions.

ifb0      no wireless extensions.

teql0     no wireless extensions.

ifb1      no wireless extensions.

root@turris:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'VHT20'
        option country 'CZ'
        option txpower '23'
        option channel '36'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk2+tkip+aes'
        option network 'lan'
        option ssid 'yyy'
        option key 'xxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option txpower '19'
        option country 'CZ'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option encryption 'psk2+tkip+aes'
        option network 'lan'
        option ssid 'yyy'
        option key 'xxx'


Oke here are some questions

  • Are you from Czech Republic? If not, where are you from?

Under “config wifi-device 'radio0’”

option htmode 'VHT20'
option htmode 'VHT80'

option txpower '23'
option txpower '20'

Under “config wifi-device 'radio1’”

option txpower '19'
option txpower '16'

After that try to reboot the Omnia (much easier then disable and enable stuff which you maybe connected to it by wifi.

It should be IT, but I changed back to CZ (factory deafult) just to get the three DbM more on the 5Ghz (in IT the limit is 200mW for the a bands, so 23 should be OK as well).
I can try the 80MHz channel on the 5Ghz, but changing radio1 config seems a bit useless as the output power is anyway 16 (as shown in the above output) no matter if you put an higher value.

I have experimented with 5GHz with different tx-power. The 5GHz wifi-card supports to a MAX of 20 tx-power. When i set it higher then 20 tx-power, then it disabled it self and did not work anymore.

Radio1 2.4 GHz, supports to a max of 16 it self. So setting it on 17 or higher won’t change anything, because of the limit that it is giving.

So about the 5 GHz, do try my configuration settings first and if things still don’t work, then we can try something else. Also do not change the channel, leave it on 36.

Btw, 5GHz disconnecting occasionally is normal since 3.3. I also suffer from that problem, all though i directly reconnects it self back on the network.

You’re not wrong pointing towards 5GHz-connections but unfortunately that doesn’t solve the problem of coverage.
There are older laptops and also newer Internet-of-the-Things-devices (LifX eg) that don’t support 5GHz & you have to setup some access-points (aps) to cover the whole area of your property (or even some more - depending on the dimensions of you property).
And aside this - imagine your normal working area is completely covered by 5GHz and you would rarely leave this working area. But when you leave it, your cellphone (tablet, whatever) doesn’t have access anymore. Plus for your cellphone you don’t really need 433Mbit - if you need speed (doing a backup or copying music/pictures etc) you will directly connect it to your PC/Mac. So speed doesn’t really matter on cellphones.
And for backups/copying large files even 5GHz is still no option (even with decent hardware and good conditions you will perhaps get 50 to 60MiB/s sustained speed) - here we will have to wait for 802.11ad (16GHz) to enter the market. Thus you still need a wired connection to get satisfying speeds (my server r/w at about 160MiB/s so I will need so setup a SFP->2,5Gb/s-connection, but that is being discussed somewhere else).

So in conclusion:

  • 2,4GHz (with great tx-power and high +dBi-antennas) is the base-coverage for the whole property giving you access wherever you are. Optimum would be 1 main router and 1-2 access points. If you don’t need 5GHz, you should stick to something like WRT1900AC and replace the antenna with the link I posted above.
  • 5GHz (with still good tx-power needed to lower the number of your aps) covers your living/working room giving you multimedia-experience
  • Wired Connections (or perhaps later on 16GHz) give you the satisfactory speed for real data-operations

Coming back to the problem - the given 2,4GHz-card doesn’t offer enough tx-power.
Therefore I am thinking about replacing it with a 3*3/20dBm(better 30dBm)-card that is supported by the os. Does anybody know which one to pick and what has to be done to get this idea working? Getting holes into the chassis and installing connectors would be the least problem…

Look closely at the back of your TO’s chassis. There are additional holes already.