Transmission not working in TurrisOS 4.0.3 with seccomp hardening packages

After upgrading to TurrisOS 4.0.3 on an Omnia NAS, transmission is no longer working. The LuCI config page looks ok, but the transmission daemon is not running at all. If I try to start it from the command line with /etc/init.d/transmission start, i get the following error in /var/log/messages:

Jan 13 15:50:22 asgard transmission: Starting with 1033992000 virt mem
Jan 13 15:50:22 asgard : jail: not root, aborting: No error information
Jan 13 15:50:22 asgard transmission-daemon[31937]: jail: not root, aborting: No error information

I tried to remove the config files and directory, and re-install. Transmission wouldn’t start either from the init script or LuCI, and the error (from init script) stays the same. Upon further investigation - the config directory gets created after starting the init script, and running transmission-daemon -g /tmp/transmission/ manually worked.

Finally, it turned out the problem was in the (experimental) seccomp hardening packages. I didn’t get far trying to solve the problem, and ended up removing the hardening packages (through Foris) - now transmission works.

Should I file a bug about the seccomp issue somewhere? (I’m on 4.0.3, HBS)