TOS6 hostapd not starting ("command not found")

Need help to debug this one further. Just switched to HBD and have issues bringing wireless up. It looks like hostapd is not starting see logs below. Does anyone know how/where to enable more debug output so I can see what command has not been found?

Sep 20 12:15:58 omnia netifd: radio0 (3404): Command failed: Request timed out
Sep 20 12:15:58 omnia netifd: radio0 (3404): Command failed: Not found
Sep 20 12:15:58 omnia netifd: radio0 (3404): Device setup failed: HOSTAPD_START_FAILED
Sep 20 12:15:58 omnia netifd: radio1 (3405): Command failed: Request timed out
Sep 20 12:15:58 omnia netifd: radio1 (3405): Command failed: Not found
Sep 20 12:15:58 omnia netifd: radio1 (3405): Device setup failed: HOSTAPD_START_FAILED

I can see the config in ps output

root     10346  2474  2 13:21 ?        00:00:00 /bin/sh ./mac80211.sh mac80211 setup radio0 {"config":{"channel":"36","hwmode":"11a","path":"soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0","htmode":"VHT80"},"interfaces":{"0":{"bridge":"br-lan","bridge-ifname":"br-lan","config":{"mode":"ap","ssid":"Turris","encryp
root     10489 10346  0 13:21 ?        00:00:00 ubus wait_for hostapd

versions

root@omnia:~# uname -a
Linux omnia 5.4.143 #0 SMP Sun Sep 19 23:53:31 2021 armv7l GNU/Linux
root@omnia:~# cat /etc/turris-version 
6.0
root@omnia:~# cat /etc/openwrt_*
DISTRIB_ID='TurrisOS'
DISTRIB_RELEASE='6.0'
DISTRIB_REVISION='r16290+58-a44fd27070'
DISTRIB_TARGET='mvebu/cortexa9'
DISTRIB_ARCH='arm_cortex-a9_vfpv3-d16'
DISTRIB_DESCRIPTION='TurrisOS 6.0 a44fd27070e9fbd41dfa25585520f4b8937471cf'
DISTRIB_TAINTS='busybox'
a44fd27070e9fbd41dfa25585520f4b8937471cf
root@omnia:~# opkg list-installed |egrep "ath10|wpa|hosta"
ath10k-board-qca988x - 20201118-3
ath10k-firmware-qca988x-ct - 2020-11-08-1
hostapd-common - 2020-06-08-5a8b3662-35
kmod-ath10k-ct - 5.4.143+2021-06-03-b44cd7b2-2-309dc17402ddc09cc345cfeccb3ad660
wpad - 2020-06-08-5a8b3662-35
root@omnia:~# hostapd -v
hostapd v2.10-devel
User space daemon for IEEE 802.11 AP management,
IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
Copyright (c) 2002-2019, Jouni Malinen <j@w1.fi> and contributors

root@omnia:~# which hostapd
/usr/sbin/hostapd

wifi config

root@omnia:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Turris'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:03.0/0000:03:00.0'
	option htmode 'HT20'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Turris'
	option encryption 'none'

I’ve noticed that /tmp/run/hostapd-phy0.conf and /tmp/run/hostapd-phy1.conf are configured correctly and running hostapd with those configs brings wifi online just fine. Then I’ve stumbled on this workaround
https://bugs.openwrt.org/index.php?do=details&task_id=3018

Don’t touch anything, simply from shell: service wpad enable && service wpad start && reboot. Enjoy your WiFi!