TO in dumb AP mode does not relay DHCP to WLAN clients

I’m trying to set up my TO again after a clean medkit install of 5.0.1 installation from scratch. My network setup is as described here:
https://openwrt.org/docs/guide-user/network/wifi/dumbap

Basically I’m using my ISPs router box for Internet access and DHCP. The TO should be a client in the LAN and a WIFI access point. Everything works fine after setting up the network bridge for wired clients. WLAN clients however do not get an IP assigned. Manually assigning one works. So the network bridge is forwarding packages.
Per the instructions I disabled the firewall, odhcp and dnsmasq services.

What am I missing here? This setup worked under TO 3.x before…

from /etc/config/network:

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option bridge_empty '1'
        option ipaddr '192.168.128.2'
        option _turris_mode 'unmanaged'
        option gateway '192.168.128.1'
        list dns '192.168.128.1'
        list ifname 'lan0'
        list ifname 'lan1'
        list ifname 'lan2'
        list ifname 'lan3'
        list ifname 'lan4'

and from /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '04:f0:21:24:0e:6e'
        option country 'DE'
        option disabled '0'
        option legacy_rates '0'
        option hwmode '11a'
        option htmode 'VHT40'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'foobar'
        option disabled '0'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'
        option key 'redacted'

Why not use ISP router in bridge mode and use TOS as used to? (most isp routers can run in bridge mode).
… btw: that guide stated:
Summary: This document describes how to create a Dumb Access Point (Dumb AP) that extends a network that already has a “main router”. It’s called a “Dumb Access Point” because it does not provide routing or DHCP

So dhcp comes from that ISP router … maybe you have to run it not in “dumb” mode, but having your TOS dhcp at least relaying/forwarding requests to ISP router’s dhcp. Also you should use “wlan” ifaces via bridge , which you have, but you are listing each lanX and not the wlan ifaces? there you should use ethX instead, maybe?.

…I think that instead list ifname 'lanX' for each you should use option ifname 'lan1 lan2 lan3 lan4 default_radio0' for all in one line. And similarly “dns” should be option dns '192.168.128.1'