TIM FTTH with SFP directly connected to Turris Omnia (or ONT of TIM and Turris Omnia in cascade)

Hi, I’m strongly attracted to Turris Omnia, but I don’t know if it’s possible to use it with my system. I have a FTTH of the TIM in Italy. I have the operator’s SFP inserted in the ONT integrated in the modem/TIM-HUB-Modem-Router-ADSL-ADSL2-VDSL-EVDSL router always of the operator. I would like to know if it is possible to use the TIM SFP directly in the Turris Omnia ONT or if it is possible to connect it in cascade to an ONT provided by TIM to use the Turris as a router.

As far as I can tell the TH does not provide ONT functionality, and neither does the TO, but requires a transceiver to be inserted into the TH’s SFP cage

or alternatively


For either scenario it should be feasible to replace/substitute the TH with the TO instead. Did you give a try?

Or else, it is of course possible to cascade the TO after the TH but that would seem sort of overkill (energy consumption, occupancy of space, cabling, network complexity) since both are powerful router devices.

In fact, my aim is to simply replace the TIM Hub with the Turris Omnia, but I don’t know if Turris Omnia’s SFP cage is compatible with the TIM SFP. I didn’t do any tests, because to buy the Turris I would like to be sure it was feasible. On the TIM site (of which you report pieces) the TIM Hub can be used directly as an ONT or connected in cascade to an external ONT. But TIM says that the external ONT must be of the TIM.

The TH is apparently manufactured to specs for the services TIM is providing to its subscribers. However, and without knowing the design specifications, the SFP cage in the TH is probably the same (standard) as in the TO.


Maybe some other TIM subscriber with a TO can advise, that it was you are looking for I suppose.


That is the usual installation scenario - ISP provides either:

  • their ONT (device) that features connectivity ports (ethernet, fibre) for downstream devices (router),

and/or:

  • SFP transceiver (which basically does the ONT bit) to be used with a router’s SFP

So, if TIM:

  • did not install an (exterior) ONT at your premises then there is nothing that can be connected to and the SFP transceiver to be used (which is not clear but seems to be case here),

and/or

  • did install an (exterior) ONT device then likely you can connect the TO to it via ethernet - check the specifications of the ONT that is installed (if any)

Ok, my case is the first and I don’t have an ONT installed. Your explanation helped me a little. I don’t know how fiber works, I thought an ONT was needed and that the SFP couldn’t convert light into data. I think I will buy the Turris Omnia a and I will try directly to insert the TIM SFP in the TO cage.

If you decide to procure the TO you probably would like to be aware that its current TOS4.0x implementation does not activate connectivity on its SFP cage automatically

1 Like

Thank you very much, you were really helpful.

I don´t know TIM as a provider, but sometimes you also need to configure a VLAN for the WAN to get a connection to your provider. For example for me i had to set the following but i use a swiss provider so for you it could be something different:

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth2.10'

That should be only if it is connected via WAN port to external ONT (and in that case TIM provides the parameters for the creation of the dedicated VLAN). In the case of direct use of the SFP cage I think it is not necessary.

In the end I bought and received the Turris Omnia 2019 2GB. I inserted the cable with SFP and nothing works as expected. I don’t know which version was basic, but being supernoob I flashed version 4.0.1 via USB. I access everything, but the SFP port still doesn’t work (I think). Of course I follow the suggestion of @n8v8r and from ssh I gave ln -sf armada-385-turris-omnia-sfp.dtb / boot / dtb && reboot. The router restarts, but it still seems to not work. How can I verify that the port is active? In dmesg there is no item related to sfp.

EDIT:I was wrong about something. Now sfp results in dmesg, but I still can’t configure the port. I enclose the output of dmesg.

Sounds like TIM requires VLAN on the WAN port but you would know better. Whilst VLAN might have been shipped preconfigured with the TH it is not with the TO and needs to be setup, that is if VLAN a/o any other potential subscriber identification is required by the ISP.

Please, you my only hope. Should you turn on some led on the router? From the dmesg do you think SFP works? Below configiration from TIM page:

  • USERNAME: phone_number
  • PASSWORD: timadsl
  • PROTOCOLLO: PPPoE Routed (definito come RFC 2516)
  • INCAPSULAMENTO: VLAN Ethernet 802.1q
  • NAT: attivo
  • VLAN: 835

That (diagnostics) looks good thus far, the TO is communicating with the SFP transceiver in TO’s SFP cage.


You need to setup PPPoE authentication for the WAN port and enable VLAN as well.

Not sure how familiar you are yet with the device and the two management UIs being provided - Foris (by the TOS development) and LuCI (by OpenWrt development). Also there is bare bone management via ssh browser.

Last time I checked Foris did not provide an option to configure VLAN for the WAN port, but that might have changed. In which case better use LuCI or ssh.

For ssh edit this file /etc/config/network, supposedly the wan part should look something like:

config interface 'wan'
	option proto 'pppoe'
	option username 'your username herer'
	option password 'your password here'
	option peerdns '0'
	option ipv6 'auto'
	option keepalive '6 10'
	option ifname 'eth2.835'

After saving the changes the network needs to be restarted, perhaps best to reboot the TO though

1 Like

I put that data in the file in /etc/config/network and in fact the configuration is reflected in LuCI, but after restarting it still doesn’t work. Is there a way to understand what the problem is?

Keep an eye on the syslog (LuCi). There should be messages related to WAN/PPPoE connectivity (errors).

In the end I managed to solve. The procedure is correct, that is the configuration of the 835 interface requested by the operator. The problem is Turris 4. After burning the disk of Omnia by dint of reflashing the image, in the end, desperate, I thought I’d go back to version 3 with which the router was delivered to me. Everything works perfectly on Turris 3, except that in Foris it gives me an error both when I check the connection on the WAN and when I check the DNS. But in reality they work both. Will they fix version 4 or will I be forced to stay on 3? I believe on 4 the problem is just the VLAN that doesn’t work and not so much the interface. Because the VLAN section is missing in both LuCI and in the /etc/config/network file.