The 2.5GHz Wi-Fi connection stalls after a few minutes

I use 2.5GHz “Generic MAC80211” radio (5GHz “MediaTek MT7915E” doesn’t work for me, see the other thread).

At least several devices (not sure if all) suddenly stop transmitting data through WiFi, even though the connection still shown as active. It doesn’t recover by itself (I tried to wait for 30 minutes), but if I disconnect and reconnect the device, it works again for a few minutes (from 30 seconds to 40 minutes, I’d say).

I tried unchecking the “Disassociate On Low Acknowledgement” setting like suggested somewhere in internet, but it didn’t help.

I also tried to switch the band width to 20GHz from 40GHz (hoping for “slower but more reliable” connection), but it appears to make the issue occur even more frequently. There is a difference though when I ping a host in the internet (not 100% that it depends on the band width though, I only experimented a few times). With 40GHz, pings just stop responding, but with 20GHz, pings slowly go up to 10 seconds (!) before the connections stalls.

Any ideas?


The last message in this thread seem to mention the same problem.

It’s possible that the issue is widespread, but not many people notice it because it’s 2.5GHz only and people tend to use 5GHz recently.

The issue happens at least in Debian and Android for me, and indeed I didn’t notice it with Windows laptop.

1 Like

I’m having this problem too. Tried endlessly to “fix” it but no avail.
Turris Omnia with the Atheros AR9287 802.11bgn 2.4

Did you try to reset wifi settings in reForis?

If yes and it didn´t heleped:
Which security standard do you use? WPA2+WPA3 or WPA2 only? - I would recommend WPA2 only.
Do you have 802.11w enabled - Protected Management Frames? - If yes, set it to disabled. Option “optional” is causing problems on some devices.

Thanks for the suggestions.

WiFi reset in reForis didn’t help.

I indeed use WPA2+WPA3, and indeed “Protected Management Frames” is set to “optional”. I’ll try to switch to WPA2 only and disable “Protected Management Frames”, will write later today whether it helped.

I’ve tried these settings this morning (“Protected Management Frames” goes to “disabled” automatically when I set security to "WPA2 only), and unfortunately it didn’t help – after 20 minutes the connection to my laptop stalled again.

Then contact Turris support and they should help you.