TFTP server / PXE booting does not work

Hi Guys,

I really need a help here, does anyone has a working pxe booting setup?
First I tried to set this up with the LuCi GUI, but it didn’t work, so I added some lines to the dhcp config, that I could find in this Turris documentation:

Unfortunately it didnt work either. To be more precise, dhcp itself work, I can get an IP for the client, and also next-server address is also known, but the filename and root-path is not found.
I have tested it with Virtualbox VM network boot with iPXE and also with normal intel PXE on my physical host. Result are the same. I could check in iPXE shell that root-path and filename stringth are empty, so that is why it cannot boot, if i set it there up manually, i can boot to the pxe menu.

I do not know if it is important or not, but I do not have any NFS share for this network boot, I simply try it from Turris filesystem, so /mnt/data/tftp is not a mounted fs but it is a local fs.

Here is my /etc/config/dhcp:

config dnsmasq
option domainneeded '1’
option boguspriv '1’
option localise_queries '1’
option rebind_protection '1’
option rebind_localhost '1’
option domain 'lan’
option expandhosts '1’
option authoritative '1’
option readethers '1’
option leasefile '/tmp/dhcp.leases’
option resolvfile '/tmp/’
option localservice '1’
option dhcpscript '/etc/resolver/’
option port '0’
option nonwildcard '0’
option local '/lan/'
option enable_tftp '1’
option dhcp_boot 'pxelinux.0’
option tftp_root ‘/mnt/data/tftp/’

config boot 'linux’
option filename 'pxelinux.0’
option serveraddress '’
option servername ‘Turris’

config dhcp 'lan’
option interface 'lan’
option start '100’
option limit '150’
option leasetime '12h’
option dhcpv6 'server’
option ra 'server’
option ignore '0’
list dhcp_option ‘6,’

config dhcp 'wan’
option interface 'wan’
option ignore ‘1’

config odhcpd 'odhcpd’
option maindhcp '1’
option leasefile '/tmp/hosts/odhcpd’
option leasetrigger ‘/usr/sbin/odhcpd-update’

Please advice what could be wrong in my config?? Anyone has a working solution?
Thanks in advance

Here is the virtualbox result while booting an empty vm with network booting:

Ok, I solved my own issue. Here is resolution if someone expect some similar issues.
The problem was probably that I have had some hostname and other configuration on the router, so i ended up deleting the /etc/config/dhcp config file and reinstalling dnsmasq and odhcp packages. Thereafter I simply edited the tftp settings in the luci gui, and everything was working as expected.