T 1.0 po migraci nefunguje 5GHz

Zmigroval se mi T 1.0. Vse vypada ze jede krome 5GHz AC site na Qualcomm Atheros QCA9880 802.11bgnac
Device mi pise not active, restart nepomaha, zkusil jsem sit smazat a vytvorit znova, ale bez uspechu.

Log (je nomalni,ze kernel je o hodinu posunuty?)

Jan 17 20:04:46 turris hostapd: Configuration file: /var/run/hostapd-phy0.conf
Jan 17 21:04:47 turris kernel: [1164259.084080] ath10k_pci a000:05:00.0: pdev param 0 not supported by firmware
Jan 17 21:04:47 turris kernel: [1164259.105302] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 17 20:04:47 turris hostapd: wlan0: INTERFACE-ENABLED
Jan 17 20:04:47 turris hostapd: wlan0: INTERFACE-DISABLED
Jan 17 20:04:47 turris hostapd: nl80211: Could not configure driver mode
Jan 17 20:04:47 turris hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Jan 17 20:04:47 turris hostapd: nl80211 driver initialization failed.
Jan 17 20:04:47 turris hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Jan 17 20:04:47 turris hostapd: wlan0: AP-DISABLED
Jan 17 20:04:47 turris hostapd: wlan0: CTRL-EVENT-TERMINATING
Jan 17 20:04:47 turris hostapd: hostapd_free_hapd_data: Interface wlan0 wasn’t started
Jan 17 20:04:47 turris netifd: radio2 (30227): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 9870 path ()
Jan 17 20:04:47 turris netifd: radio2 (30227): Device setup failed: HOSTAPD_START_FAILED

/var/run/hostapd-phy0.conf

driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
hw_mode=a
beacon_int=100
channel=100

tx_queue_data2_burst=2.0
ieee80211n=1
ht_coex=0
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-79 35][DSSS_CCK-40]
vht_oper_chwidth=1
vht_oper_centr_freq_seg0_idx=106
ieee80211ac=1
vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][RX-ANTENNA-PATTERN][TX-ANTENNA-PAT TERN][RX-STBC-1][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7]

interface=wlan0
ctrl_interface=/var/run/hostapd
ap_isolate=1
bss_load_update_period=60
chan_util_avg_period=600
disassoc_low_ack=1
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
utf8_ssid=1
multi_ap=0
wpa_passphrase=HESLO_SITE
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=JMENO_SITE
bridge=br-lan
wpa_disable_eapol_key_retries=0
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
bssid=xx:xx:xx…

/etc/config/wireless

config wifi-device ‘radio0’
option type ‘mac80211’
option path ‘ffe09000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0’
list ht_capab ‘LDPC’
list ht_capab ‘SHORT-GI-20’
list ht_capab ‘SHORT-GI-40’
list ht_capab ‘TX-STBC’
list ht_capab ‘RX-STBC1’
list ht_capab ‘DSSS_CCK-40’
option country ‘CZ’
option disabled ‘0’
option hwmode ‘11a’
option htmode ‘VHT80’
option channel ‘120’

config wifi-device ‘radio1’
option type ‘mac80211’
list ht_capab ‘LDPC’
list ht_capab ‘SHORT-GI-20’
list ht_capab ‘SHORT-GI-40’
list ht_capab ‘TX-STBC’
list ht_capab ‘RX-STBC1’
list ht_capab ‘DSSS_CCK-40’
option country ‘CZ’
option hwmode ‘11g’
option txpower ‘18’
option htmode ‘HT40’
option disabled ‘0’
option channel ‘11’
option macaddr ‘60:02:b4:7d:88:95’

config wifi-iface ‘wifinet1’
option device ‘radio1’
option network ‘lan’
option mode ‘ap’
option ssid ‘JINA_SIT’
option key ‘JINY_HESLO’
option disabled ‘0’
option encryption ‘psk2+tkip+aes’

config wifi-device ‘radio2’
option type ‘mac80211’
option hwmode ‘11a’
option htmode ‘VHT80’
option channel ‘100’
option macaddr ‘04:f0:21:22:8f:21’
option legacy_rates ‘0’
option country ‘CZ’

config wifi-iface ‘guest_iface_0’
option disabled ‘1’

config wifi-iface ‘guest_iface_1’
option disabled ‘1’

config wifi-iface ‘wifinet3’
option ssid ‘JMENO_SITE’
option encryption ‘psk2’
option device ‘radio2’
option mode ‘ap’
option network ‘lan’
option key ‘HESLO_SITE’

Ano, je, některé výpisy jsou o hodinu.
Zkuste odpojit napájení, někdy jen reboot nestačí.

Jako uprimne ty hodiny mi zas tak moc nevadi - na rozdil od ty wifiny. :smile:

To chápu. hele, mě se to taky stalo a připadalo mi, že karty nejsou správně detekované a jsou jakoby prohozené. Mrkni do ReForis, zkus je vypnout, vymazat nastavení, restartovat a zase nastavit. Ale podle prvního dotazu jsi to už asi zkusil.

Ja na to sel pres Luci. Mam zkusit reForis? Navic 2.4GHz na druhy karte mi jede ok.

To mně jelo taky, jen jedna karta. Hele, za pokus nic nedáš a rozjet to potřebuješ.

ok, lame dotaz. Jak se dostat do reforisu? Kdyz jdu rovnou na IP, hodi me to do Luci bez moznosti vyberu.
Zkusil jsem IP/reforis/login ale to neexistuje…
???

balicek reforis je nainstalovany (spolu s dalsimi reforis balicky) - nicmene treba reforis openvpn ne.
Zmigrovalo se mi to ok?

Adresa je http://tvoje_ip/reforis/login

Asi ti něco nedoběhlo…

Tohle by ti mohlo pomoct:

Souhrn

root@mox:~# opkg list | grep reforis
reforis - 1.1.2-3.7-1 - Web administration interface for Turris router.
reforis-data-collection-plugin - 0.3.2-3.7-1 - reForis Data Collection plugin
reforis-data-collection-plugin-l10n-cs - 0.3.2-3.7-1 - reforis-data-collection-plugin-l10n-cs
reforis-data-collection-plugin-src - 0.3.2-3.7-1 - reForis Data Collection plugin. (Contains the Python3 sources for this package).
reforis-diagnostics-plugin - 2.5.1-3.7-1 - reForis diagnostics plugin.
reforis-diagnostics-plugin-l10n-cs - 2.5.1-3.7-1 - reforis-diagnostics-plugin-l10n-cs
reforis-diagnostics-plugin-src - 2.5.1-3.7-1 - reForis diagnostics plugin… (Contains the Python3 sources for this package).
reforis-distutils - 0.1.0-3.7-3 - Distutils to build reforis and its plugins.
reforis-distutils-src - 0.1.0-3.7-3 - Distutils to build reforis and its plugins… (Contains the Python3 sources for this package).
reforis-haas-plugin - 0.1.3-3.7-1 - reForis Honeypot as a Service plugin
reforis-haas-plugin-l10n-cs - 0.1.3-3.7-1 - reforis-haas-plugin-l10n-cs
reforis-haas-plugin-src - 0.1.3-3.7-1 - reForis Honeypot as a Service plugin. (Contains the Python3 sources for this package).
reforis-l10n-cs - 1.1.2-3.7-1 - reforis-l10n-cs
reforis-l10n-da - 1.1.2-3.7-1 - reforis-l10n-da
reforis-l10n-de - 1.1.2-3.7-1 - reforis-l10n-de
reforis-l10n-el - 1.1.2-3.7-1 - reforis-l10n-el
reforis-l10n-en - 1.1.2-3.7-1 - reforis-l10n-en
reforis-l10n-es - 1.1.2-3.7-1 - reforis-l10n-es
reforis-l10n-fi - 1.1.2-3.7-1 - reforis-l10n-fi
reforis-l10n-fo - 1.1.2-3.7-1 - reforis-l10n-fo
reforis-l10n-fr - 1.1.2-3.7-1 - reforis-l10n-fr
reforis-l10n-hr - 1.1.2-3.7-1 - reforis-l10n-hr
reforis-l10n-hu - 1.1.2-3.7-1 - reforis-l10n-hu
reforis-l10n-it - 1.1.2-3.7-1 - reforis-l10n-it
reforis-l10n-ja - 1.1.2-3.7-1 - reforis-l10n-ja
reforis-l10n-ko - 1.1.2-3.7-1 - reforis-l10n-ko
reforis-l10n-lt - 1.1.2-3.7-1 - reforis-l10n-lt
reforis-l10n-nb_NO - 1.1.2-3.7-1 - reforis-l10n-nb_NO
reforis-l10n-nl - 1.1.2-3.7-1 - reforis-l10n-nl
reforis-l10n-pl - 1.1.2-3.7-1 - reforis-l10n-pl
reforis-l10n-ro - 1.1.2-3.7-1 - reforis-l10n-ro
reforis-l10n-ru - 1.1.2-3.7-1 - reforis-l10n-ru
reforis-l10n-sk - 1.1.2-3.7-1 - reforis-l10n-sk
reforis-l10n-sv - 1.1.2-3.7-1 - reforis-l10n-sv
reforis-netboot-plugin - 0.4.0-3.7-1 - reForis Netboot plugin.
reforis-netboot-plugin-l10n-cs - 0.4.0-3.7-1 - reforis-netboot-plugin-l10n-cs
reforis-netboot-plugin-src - 0.4.0-3.7-1 - reForis Netboot plugin… (Contains the Python3 sources for this package).
reforis-netmetr-plugin - 0.3.0-3.7-1 - ReForis NetMetr Plugin
reforis-netmetr-plugin-l10n-cs - 0.3.0-3.7-1 - reforis-netmetr-plugin-l10n-cs
reforis-netmetr-plugin-src - 0.3.0-3.7-1 - ReForis NetMetr Plugin. (Contains the Python3 sources for this package).
reforis-openvpn-plugin - 1.5.0-3.7-1 - Reforis OpenVPN plugin.
reforis-openvpn-plugin-l10n-cs - 1.5.0-3.7-1 - reforis-openvpn-plugin-l10n-cs
reforis-openvpn-plugin-src - 1.5.0-3.7-1 - Reforis OpenVPN plugin… (Contains the Python3 sources for this package).
reforis-remote-access-plugin - 1.3.0-3.7-1 - reForis Remote Access Plugin.
reforis-remote-access-plugin-l10n-cs - 1.3.0-3.7-1 - reforis-remote-access-plugin-l10n-cs
reforis-remote-access-plugin-src - 1.3.0-3.7-1 - reForis Remote Access Plugin… (Contains the Python3 sources for this package).
reforis-remote-devices-plugin - 1.4.1-3.7-1 - reForis Remote Devices plugin
reforis-remote-devices-plugin-l10n-cs - 1.4.1-3.7-1 - reforis-remote-devices-plugin-l10n-cs
reforis-remote-devices-plugin-src - 1.4.1-3.7-1 - reForis Remote Devices plugin. (Contains the Python3 sources for this package).
reforis-remote-wifi-settings-plugin - 0.2.1-3.7-1 - reForis Remote Wi-Fi Settings Plugin
reforis-remote-wifi-settings-plugin-l10n-cs - 0.2.1-3.7-1 - reforis-remote-wifi-settings-plugin-l10n-cs
reforis-remote-wifi-settings-plugin-src - 0.2.1-3.7-1 - reForis Remote Wi-Fi Settings Plugin. (Contains the Python3 sources for this package).
reforis-snapshots-plugin - 1.2.1-3.7-1 - reForis snapshots plugin
reforis-snapshots-plugin-l10n-cs - 1.2.1-3.7-1 - reforis-snapshots-plugin-l10n-cs
reforis-snapshots-plugin-src - 1.2.1-3.7-1 - . (Contains the Python3 sources for this package).
reforis-src - 1.1.2-3.7-1 - Web administration interface for Turris router… (Contains the Python3 sources for this package).
reforis-storage-plugin - 0.2.2-3.7-1 - reForis Storage plugin
reforis-storage-plugin-l10n-cs - 0.2.2-3.7-1 - reforis-storage-plugin-l10n-cs
reforis-storage-plugin-src - 0.2.2-3.7-1 - reForis Storage plugin. (Contains the Python3 sources for this package).

Si smazal co mas nainstalovany a bouchl sem vsechno :smiley:
Jasne, reforis balicky jsem nasel…ale to mi moc nepomohlo - jeste nez si to smazal, tak jsem odkontroloval co ty mas a ja ne a sladil to. Nemam HaaS balicky, ale ty IMHO nepotrebuju.

https://192.168.x.y/reforis/login
The requested URL /reforis/login was not found on this server.

reforis - 1.1.2-3.7-1
reforis-data-collection-plugin - 0.3.2-3.7-1
reforis-data-collection-plugin-l10n-cs - 0.3.2-3.7-1
reforis-diagnostics-plugin - 2.5.1-3.7-1
reforis-diagnostics-plugin-l10n-cs - 2.5.1-3.7-1
reforis-l10n-cs - 1.1.2-3.7-1
reforis-netmetr-plugin - 0.3.0-3.7-1
reforis-netmetr-plugin-l10n-cs - 0.3.0-3.7-1
reforis-openvpn-plugin - 1.5.0-3.7-1
reforis-openvpn-plugin-l10n-cs - 1.5.0-3.7-1
reforis-snapshots-plugin - 1.2.1-3.7-1
reforis-snapshots-plugin-l10n-cs - 1.2.1-3.7-1
reforis-storage-plugin - 0.2.2-3.7-1

Promiň:

root@mox:~# opkg list-installed | grep reforis*
reforis - 1.1.2-3.7-1
reforis-data-collection-plugin - 0.3.2-3.7-1
reforis-data-collection-plugin-l10n-cs - 0.3.2-3.7-1
reforis-diagnostics-plugin - 2.5.1-3.7-1
reforis-diagnostics-plugin-l10n-cs - 2.5.1-3.7-1
reforis-haas-plugin - 0.1.3-3.7-1
reforis-haas-plugin-l10n-cs - 0.1.3-3.7-1
reforis-l10n-cs - 1.1.2-3.7-1
reforis-l10n-de - 1.1.2-3.7-1
reforis-netmetr-plugin - 0.3.0-3.7-1
reforis-netmetr-plugin-l10n-cs - 0.3.0-3.7-1
reforis-openvpn-plugin - 1.5.0-3.7-1
reforis-openvpn-plugin-l10n-cs - 1.5.0-3.7-1
reforis-snapshots-plugin - 1.2.1-3.7-1
reforis-snapshots-plugin-l10n-cs - 1.2.1-3.7-1
reforis-storage-plugin - 0.2.2-3.7-1

nemam nemcinu. haas jsem si nainstaloval, to proti nicemu neni. Zbytek balicku stejnej. Login stranka reforisu ale neexistuje.

Nemel by existovat proces reforis pokud by to bezelo?

root@turris:~# ps aux -H | grep reforis
root 13171 0.0 0.0 1492 968 pts/0 S+ 21:31 0:00 grep reforis

A cte to tady jeste nekdo jinej? Wifi nejede, reforis nejede… :confused:

root@mox:~# ps aux -H | grep reforis
root      3566  0.0  0.0   1308   560 pts/0    S+   21:36   0:00         grep reforis

Asi se raději vrať přes snapshot zpět a zkus migraci znova.

Nebo bych zkusil rovnou načíst aktuální verzi bez migrace a nastavit router na čisto - u mě tohle zabralo a taky jsem měl v minulosti problém s 5 GHz wifi

1 Like

Bohuzel je v tuhle chvili router 750km daleko, takze se nemuzu ted pustit do takovych zasahu. :frowning:
Jedna dobra zprava je, ze po nekolikatym restartu se 5GHz rozjela. (maaaaaagic :smiley: ) Takze zbyva “jen” nefunkcni reforis.

To mi dělá Turris Omnia od novoty, 5GHz jsem přestal používat protože to funguje jak nasliněné, je tak 50% šance že při rebootu naběhne a co jsem četl mělo s tím problém spousta lidí.