Syslog-ng sending logs via udp to log-server not working

In Luci in System - System - Logging i set “External system log server” “External system log server port” and “External system log server protocol” and restarted syslog-ng i also tried to reboot my MOX. The server didn’t receive any messages.

On standard Open-WRT devices this works, is there any reason why this should not work on TOS4?

It has been asked/clarified in this forum previously (forum search).

Please see also https://openwrt.org/docs/guide-user/base-system/log.essentials as it explains what the LuCI settings you are citing referring to, which is not syslog-ng, latter not being the standard logging mechanism in OpenWrt.

1 Like

Thank you @n8v8r, for pointing this out!
I added these lines to my /etc/syslog-ng.conf:

destination remote_log_server {
udp("remotehost.local" port(514));
};
log { source(src); source(net); source(kernel); destination(remote_log_server); };

Now sending logs works as expected.