Swich ports offline if plugged during boot


#1

I’m having an issue where the switch ports will get no link if the cable is plugged in during boot. This happens for soft reboots as well as for full power cycling. Replugging the cable restores connectivity to the affected port.

I’ve tried different cables and different devices on the other end. It’s consistent for all configurations and all ports on the switch, whether VLAN tagging is turned on or not. Doesn’t happen for the WAN port (that correctly gets a link during boot).

Anyone else experienced this and/or anyone has a solution? :slight_smile:


Intermittently dead ethernet ports
LAN connection to switch not established
Client not receiving a new IPv4 address after router reboot
Client not receiving a new IPv4 address after router reboot
#2

Do you mean that if you power up router with connected cables, they will not work unless replugged? Or does it only happen for cables plugged during boot?

I cannot reproduce it in either case so maybe you’ve got somehow faulty device.

You can try to reset the switch without resetting the router like this:

# swconfig dev switch0 set reset
# /etc/init.d/network reload

#3

Yes, the first one: If cables are plugged before booting (or rebooting) the router, there’s no connectivity (indicator lights stay off, swconfig says no link).

I tried swconfig dev switch0 set reset which didn’t help.


#4

I have this problem with a (Netgear GS605 v4) Switch connected to a LAN port of my TO.


#5

I have the same issue. But only with my MacBook Pro connected over Apple Thunderbolt to Gigabit Ethernet Adapter to any of LAN ports 0-4. When I make a soft reboot (in LuCI, in basic web UI or over SSH), then I have no connection and I have to replug ethernet adapter to my notebook (or restart Thunderbolt Ethernet service).

When I make the same scenario with my Kali Linux OS running on mini PC Gigabyte Brix (Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)), it works perfectly.

So it looks like this issue is related to only some ethernet cards.

On RTO I have the latest update: OpenWrt omnia 15.05 r49274.


#6

I had this issue too. In my case few devices and interfaces worked few not.
Finally after checking cables… one of UTP cables in socket was broken :frowning:


#7

You mean that something was broken inside the router? Or one of the cables you used for testing?


#8

I’m experiencing exactly the same issue, tried with multiple cables multiple devices at other end and result is still the same, anything connected to LAN ports (any of ports 0 - 4) is not reconnected after router reboot. Ports will behave like nothing is connected in however there are cables connected in. Only solution is to replug cable, sometimes I need to replug 2 - 3 times. One my colleague bought router during campaign and has the same config as me - Silver, wifi, 2GB, LTE modem and he is experiencing the same behavior. There is definitely something wrong with LAN ports on Omnia. I already requested warranty repair/replacement from turris team no answer yet.


#9

Hi @davidhaluska, a few days ago, I did see the same behaviour on my Omnia. But lately, it’s solved. Since I made all sorts of software/configuration changes, I can’t tell what solved it, but I am pretty sure, that this is not a hardware issue. It’s configuration related; might be related to the switch config.


#10

Hi Tom,

Thank you for reply. I tested switch in default configuration and also in changed configuration and behavior was the same. I would be more than happy if this will be really only config related but so far nothing is pointing this direction.

David


#11

@Tom, any idea what you did to fix it?


#12

Okay, so I’ve done some more tests, and this issue definitely seems to be configuration-dependent for me. As far as I can tell it’s VLAN-related.

Basically, what I’m seeing is that if there are more than one tagged VLAN configured on the same port, there will be no link on the switch after a hard power cycle (i.e. cable unplugged). However, connectivity can be restored without replugging, by issuing an /etc/init.d/network restart followed by a soft reboot.

The issue also seems to depend on what is at the other end of the cable. If I connect my laptop to any port, there’s always connectivity (to that port) after a hard power cycle. I’m not sure if this is also VLAN-related: The device that doesn’t get connectivity after a power cycle is a switch that only speaks speaks tagged VLAN.

For now I’ve worked around the issue by switching the WAN and LAN4 ports (so the tagged VLANs go out over the WAN port). This seems to allow me to reliably power cycle the device and get full connectivity.


#13

@tohojo

This is useful finding. Thing is that I’m also using more than 1 tagged VLAN (exactly 10 VLANs) over switch port 4 - one near WAN. I will try to do some test tomorrow including complete router reflash and running in in factory defaults and post results.

David


#14

Yeah, that definitely seems to point towards a VLAN-related issue. FWIW, if you only need tagged VLANs on one port, just using the WAN port works for me (then the VLANs will be on eth1.X for VLAN X and can be configured in software). Then you just switch the wan config to be eth2 instead of eth1 in /etc/config/network, and carry on as usual :slight_smile:


#15

I mean my own home cabling was the issue.
It worked with my old router and switch etc.
Maybe omnia electronic is more sensitive.


#16

Hi All,

Today I performed some tests, unfortunately for me it doesn’t seems to be configuration issue. My router is suffering by LAN ports issue even after factory defaults without custom configuration without VLANs. I’m experiencing this issue everytime when SW rebooted or reset button rebooted. When unplugged for 5 - 10s from power supply it will usually correctly bring up all lan ports, but when disconnected for more than 1 minute or so then it is not able to bring LAN ports up during boot, which seems to be like HW issue. I’m sending router for warranty repair.

David


#17

As another data point, I’m also experiencing the same issue. If connected during boot, the Ethernet ports remain “disconnected”. I need to physically disconnect and reconnect them (either to the same or to a different port).


#18

Same issue. I do it by powering off/on my switch.


#19

I’m experiencing the same issue with ethernet ports not connecting if they are plugged in at boot. How/where did you contact the Turris team? I can’t seem to find any official support contact information.


#20

Hi Gerco,

Mail them to info@turris.cz.

David