Some devices can't see 5 GHz WiFi

Hi guys, I set up my Omnia router with both 5 GHz and 2.4 GHz wifi. Some devices - MacBooks and iPhone, PS4 can see the 5Ghz wifi without any issues but my Raspberry Pi 4B and Samsung TV only see 2.4Ghz wifi network. I should note that both TV and RPi supports 5Ghz wifi :slight_smile:

Didn’t make any HW changes. Just basic setup, no fiddling.

Turris OS: 6.2.2
S/N: 61203286892


What country code, channel and channel width do you use? And maybe also type of encryption but that shouldn’t be issue with not seeing the ssod, just with connecting to it in some cases. Last question that come to my mind is if it’s hidden ssid or not.

80.11ac - 20 MHz
Country code: CZ
Channel: 161 (5805 MHz)
Encryption: WP3 with WPA 2 as fallback (also tried WPA2)

SSID is not hidden.

After today’s change (from 40MHz to 20MHz) and WPA2 to WP3 it stopped working for Macbook and iPhone it just keeps asking for password.

Did you delete the WLAN profile from Mac and iphone before (or after) changing it on the Turris?

I would suggest channel between 32-68 at least for testing purpose if it’s not the issue.

Hi Mike, thx, I did ignore the previous network.

Changed the channel to 60, same results. iPhone says “Cannot connect”, Mac keeps asking for password infinitely.

But what about Raspberry and TV? :slight_smile:

Hi @adamzmoravy,

could you try disabling the Management Frame Protection (MPF) in reforis?


MPF may cause issues with authentication to wifi AP that uses WPA3 encryption (both just WPA3 or transitional WPA2/WPA3) on various devices (phones, tablets, laptops, …). Depending on how well is the WPA3 implemented on such devices.

That looks very odd.

Does the TV and RPi use the same regional settings as your Omnia?
There might be a mismatch between which 5 GHz channels are allowed to be used (or somehow limited) on these devices and wifi AP, due to the regulations.

I think some channels are unsupported: Some 5 GHz wifi channels are disabled in Raspberry Pi 4 - #7 by BS86 - Installation - EndeavourOS

That same may be for TV.

But my advice is to choose the lowest availaible and free channel, because the lower frequency, the better coverage.

Thanks for you suggestions.

I did set-up the channel to 60 which solved the issue for Samsung TV and for Raspberry as well.

Now I have a feeling that there’s something wrong with my 5 Ghz module in general as I came home after few hours and 5 Ghz wifi is not available - visible - on NONE of the devices now. Tried to restart it, didn’t help. It was working before I left.

Honestly I expected more stable and issue-free network after spending more on a router (I had almost basic TP Link Deco). Now I’m thinking about reselling this unit and getting anything else, sadly :frowning:

Maybe your 5GHz card is too hot. There were such proiblems in the past. You can try to turn router off for longer time, to let the card to cool down. If it will be working then, temperature was the cause.

You can buy some cooling component and stick it to the 5GHz card. Something like this:

Maybe you are using DFS channels?