[SOLVED] WPS or how to connect Epson R2000

Normally I’d connect Epson R2000 using the dreaded WPS. There is no display on the device. I can enable wifi on my ISP router and connect the printer, but I hope there is a better way. I printed network status form the printer, so I have WPS-PIN code & MAC. Any suggestions how to connect the printer without using the ISP router? I use linux, so the windows software and temporary usb connection is not an option.

Printer manual [1]

[1] https://files.support.epson.com/pdf/r2000_/r2000_bs.pdf

Maybe try to enable WPS support on Omnia? I didn‘t try it and have no need for it, but google returns this guide e.g.:


I don‘t know if it‘s compatible to Turris OS

Edit: You could also set up a virtual windows PC :man_shrugging:t3:

1 Like

Thanks! I’ll give it a try. Setting up a virtual windows would the ultimate insult to my linux skills :smile:

root@turris:~# hostapd_cli wps_pbc
Selected interface ‘wlan0’

I will still recommend one page: https://wiki.openwrt.org/doc/uci/wireless#wps_options

1 Like


  1. Add wps_pushbutton to relevant section of /etc/config/wireless

    config wifi-iface
    option device 'radio1' <- I can’t shift that line right, but it’s indented
    option wps_pushbutton '1' <- I can’t shift that line right, but it’s indented

  2. reboot (<-- I’m not sure how to avoid it, but it wasn’t a problem in my case)

  3. hostapd_cli wps_pbc should return OK now

    root@turris:~# hostapd_cli wps_pbc
    Selected interface 'wlan1'

  4. Trigger pairing on the printer (long press of wifi button) and it should establish connection.

Thanks for the help gals & lads!

1 Like

Thank you for these instructions, they got me up and running! :+1:

1 Like

Enabling WPS still works, but I can’t get the Epson R2000 to connect anymore. Logs show it’s authenticated, but it doesn’t show as a new device, Leds are showing error (yellow blinks) or even better that eethernet is connected. Might be damaged printer or updated on turris. Hard to tell…