[Solved] Turris Omnia and Deutsche Telekom All-IP

This entry has two purposes:
To help others when they encounter the same problem
To propose an extension to the Turris Omnia web interface

  1. Problem and Solution
    Yesterday, my old phone line (Germany: ISDN + ADSL+) was changed to an All-IP-line. After the change, my modem (Allnet ALL0333CJ) showed a green LED for “DSL ok”, Ethernet to the Omnia was ok, but I had no connection. Checking “/var/log/messages”, I found lines about a “PADO timeout” and retries about once per minute.
    Need I say that Telekom customer service had no clue? They tried to shift the blame to me and declared the Omnia as “incompatible” (which I strongly doubted).
    Checking the internet, my son discovered reports of a VLAN tag 7 added by Telekom and also a way to set that in the Omnia. This is the patch:
    diff -ur original/etc/config/network fixed/etc/config/network
    — original/etc/config/network 2019-05-07 11:37:15.000000000 +0200
    +++ fixed/etc/config/network 2019-09-12 20:17:33.000000000 +0200
    @@ -19,7 +19,7 @@
    option ipaddr ‘192.168.0.1’

    config interface ‘wan’

    •   option ifname 'eth1'
      
    •   option ifname 'eth1.7'
        option username '00-my-long-personal-digit-string-here-0001@t-online.de'
        option password '2-more-digits-4'
        option proto 'pppoe'
      
  2. Turris Omnia web interface
    I did not find a way to display or set VLAN tags on the Omnia’s ethernet ports.
    Given that Deutsche Telekom enforces their use, I propose such a way should be added.

This can be set in Luci -> Network -> Interfaces -> WAN. There you can set protocol (e.g. pppoe). Under „Physical settings“ you can set vlan (e.g. eth1.7)