[Solved] Routeur uninstalls my packages!


I have a Turris Omnia router with automatic updates activated. I had to install few packages to get Omnia to connect at my bad fiber ISP here in france (Orange) including ip-full package.
For each update that router is doing it uninstalls that package (not the others one I had installed too): ip-full !! Why ? and how can I prevent that ? If router restarts without that package my Internet connection won’t work again !!



I looked in to this. And correct solution would be this for now:

Install("ip-full", {priority = 60})

Add this to file /etc/updater/user.lua

For long term solution I don’t see any reason why ip-full shouldn’t be installed out of the box so that will happen. And also I see now that every package we have in our lists should have lower than default 50 priority. So that will be in one of the future releases.

Adding it there I see little bit pointless as this will be obsoleted just with next minor release as I will do changes I described. For now having it on forum is enought I would say.

@cynerd Thanks for the help but unhappy it must have something wrong in your solution as when I applied it and run updater.sh it removed neardyl all packages of my router :frowning: I had to cancel immediately the change and run updater again to get router back in a normal state :rage:
If it can help here is output after adding your solution in my router:

##### Error notifications #####
Updater failed: Failed operations:
lcollect-majordomo/postrm: /usr/lib/opkg/info//lcollect-majordomo.postrm: line 2: /etc/init.d/lcollect: not found

##### Update notifications #####
 • Installed version 4.0.0-4 of package ip-full
 • Removed package nuci-nethist
 • Removed package foris-diagnostics-plugin
 • Removed package luci-i18n-ahcp-fr
 • Removed package luci-i18n-ahcp-en
 • Removed package nuci-diagnostics
 • Removed package foris-openvpn-plugin-l10n-fr
 • Removed package turris-diagnostics
 • Removed package foris-openvpn-plugin
 • Removed package nuci-ca-gen
 • Removed package ubus-ws
 • Removed package python-prctl
 • Removed package nethist
 • Removed package nuci-openvpn-client
 • Removed package luci-app-majordomo
 • Removed package python-websocket-server
 • Removed package foris-diagnostics-plugin-l10n-fr
 • Removed package foris-l10n-fr
 • Removed package lcollect-majordomo
 • Removed package coreutils-timeout
 • Removed package python
 • Removed package python-compiler
 • Removed package python-ctypes
 • Removed package python-db
 • Removed package python-distutils
 • Removed package python-gdbm
 • Removed package python-multiprocessing
 • Removed package python-ncurses
 • Removed package python-pydoc
 • Removed package python-sqlite3
 • Removed package python-unittest
 • Removed package luci-app-ahcp
 • Removed package ahcpd
 • Removed package foris
 • Removed package python-bottle-i18n
 • Removed package python-bottle
 • Removed package python-codecs
 • Removed package python-email
 • Removed package python-beaker
 • Removed package python-flup
 • Removed package python-ncclient
 • Removed package python-logging
 • Removed package python-xml
 • Removed package nuci
 • Removed package libnetconf
 • Removed package libxslt
 • Removed package ip
 • Removed package coreutils-base64
 • Removed package bzip2
 • Removed package thermometer
 • Removed package lm-sensors
 • Removed package libsensors
 • Removed package sysfsutils
 • Removed package libsysfs
 • Removed package ntpdate
 • Removed package lighttpd-mod-fastcgi
 • Removed package lighttpd-mod-redirect
 • Removed package l10n_supported
 • Removed package sqm-scripts
 • Removed package kmod-sched
 • Removed package kmod-ifb
 • Removed package iptables-mod-ipopt
 • Removed package kmod-ipt-ipopt
 • Removed package lcollect
 • Removed package python-openssl
 • Removed package python-decimal
 • Removed package tc
 • Removed package kmod-sched-core

I couldn’t test it yesterday. I had no electric power at home. And I missed that ip-full doesn’t have field that it provides ip. Forcing ip-full installation this way causes all packages depending on ip to be uninstalled. I will fix that and I will push that to next fixup release. But because you have to wait for next fixup release I would suggest you to do your workaround, disable updater and watching forum for fixup release. I am sorry for this inconvenience but it’s a bug in OpenWRT package so we have to fix it in on our side.

Edit: Did you tried it without ip-full? I just encountered this commit https://gitlab.labs.nic.cz/turris/openwrt/commit/966912b2f369db23a4e278aa10ed6f4dbde9bbf2 during my investigation. It seems to me that you are trying to do something that one of my colleagues hacked year ago. Our package ip is same as ip-full so nobody uses ip-full. (Yes this is pretty nasty and I will change it but you shouldn’t have any problems with ip)

@cynerd No worries and I have done what you suggested. I have deactivated for now the automatic updater to prevent automatic removal of ip-full :wink: Any timeframe estimation when next fixup release will be done ? or way to know when it’ll be released ? so I know when I activate back automatic update :wink:

For ip package I prefer not to tweak too much system to avoid breaking my Internet connection too long time :wink:

I am not pressing fix to fixup because ip should be effectively ip-full at the moment so there should be no point in installing ip-full. But in next minor release (planned to be out to the end of this year) I will set ip-full as default package and ip will be renamed to ip-tiny. So because of that I would say you can try to play with it even now as I am sure that ip should be enough, there is no difference between those two packages effectively. And next fixup won’t change it for now.

@cynerd Sorry to go against you but these two packages are not the same !! If I remove ip-full from my router and reboot, my WAN access is no more working ! I put it back and reboot and voilà ! WAN back working :slight_smile: So looks like my only option for now is to keep updates disabled to prevent router to remove package every six hours ?..

And if you are removing ip-full are you also reinstalling ip? Opkg is not checking commonly file collisions and this is common problem as ip executable is in both packages and removing ip-full removes that executable.

1 Like

Thanks for clarification about how opkg orks :wink: So I removed ip-full package and force-reinstall of ip package, rebooted and voilà ! It works great :slight_smile: so I got rid of ip-full package and reactivated data collection and statistics and automatic updates :wink:

Thanks for help