[SOLVED] Problem with fstab after upgrade to 3.3


after upgrade to 3.3 and reboot my mSata disk isn’t mounted. The /etc/config/fstab seem unchanged, but /etc/init.d/fstab is missing and so is /sbin/block, which was called from it in the previous version. The mount point menu in LuCI is gone too. What is the right way to mount filesystems persistently in the new TurrisOS?



# opkg search /sbin/block
block-mount - 2015-05-24-09027fc86babc3986027a0e677aca1b6999a9e14-1

Check that you have block-mount installed:

# opkg list-installed block-mount
block-mount - 2015-05-24-09027fc86babc3986027a0e677aca1b6999a9e14-1

I had to rollback to previous version, because the new one does not see my mSata disk at all (/dev/sda does not exist, no “sda” in dmesg). In the 3.2.1 version there is block-mount installed and I did not uninstall it, I have just updated to 3.3 and it was not there. So I’m back on previous version with automatic updates disabled.

I had the same problem. My solution: [Tip] Turris 3.3: Unchecked Service "NAS" removes (m)SATA at all

1 Like

Yes, that was it, problem solved. Thanks!

Can someone tell me if the fstab is supposed to be a regular file or a symbolic link, please? Surprisingly, mine points to a non-existing file:

# ls -al /etc/fstab
lrwxrwxrwx 1 root root 10 Dec 5 19:39 /etc/fstab → /tmp/fstab

And I think the timestamp corresponds to that of the 3.3 update :confused:

My impression is that OpenWRT doesn’t use /etc/fstab (or /tmp/fstab). See /etc/config/fstab.

And yes, also on my Omnia with 3.3 /etc/fstab is a symlink to /tmp/fstab that doesn’t exist.

1 Like

Thank you for the information, white! I won’t worry about my fstab, then.