[SOLVED] mDNS/Avahi/Zeroconf on bridges (e.g. br-lan)

Just a reminder to everyone wondering why mDNS-advertised devices are not showing up, e.g. avahi-daemon on servers or TimeCapsules or network printers: Multicast snooping is enabled by default on all bridges. For mDNS to work properly (means: dual stack) multicast snooping should be disabled. It is not of great use on a lan-br anyway I think.

Go to System -> Startup in LuCi, scroll down to Local Startup and add this line before exit 0

echo “0” > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping

Remember to change the br-lan part if your bridge is named differently.

Note: mDNS is IPv6 only in my network, so it may have worked via legacy IP broadcast for others so far. But as soon as you drop legacy IP in your network you might face this problem.

2 Likes