[Solved] Broken Turris Omnia (missing reForis, LuCI, infine redirect loop)

Hey guys,

yesterday, I’ve installed my 2nd Omnia to another location.

I tried to set everything the same.
My goal was:

  • Use internal mSATA SSD as /srv for LXC
  • Use external USB SSD as a storage for NAS
  • Mount external USB SSD into mnt/nas

I thought that I got it right. I had to do some harakiri in terminal (mount + fstab), but it looked OK.

Today, I found out that files stored in /mnt/nas/something/... are actually stored on the internal 8GB flash which was full.

In LuCI, I had two buttons to unmount two file systems for those two external drives. I unmounted them.
As next, I deleted the mounts in the second table on the mount point in LuCI.
After that, I wasn’t able to see reForis & Luci. WiFi worked even after reboot. When I tried to access router, it was attempting to do initial setup.

I tried

  • Reset
  • Factory reset
  • Reflash from two different USBs (mode 4)
  • SSH (mode 5)
  • Reflash from the internet

No luck. My Omnia doesn’t trigger initial setup wizard. When I try 192.168.1.1 I receive nothing, and the page goes into infinite redirect loop. No applications are show, just redirect to /login/reforis

During mode 4 LEDs sequence is

  • White Knight Rider
  • All green
  • 4 most left red
  • White Knight Rider
  • The most left LED & PCI 2 & PCI 3 goes white
  • The most left LED goes to green

After flash, I receive an IP from the router, but I receive the infinite loop again when I try to access 192.168.1.1.

The only LED which is shining is POWER with Green. I don’t think that is correct after reflash.

Any idea to get it fix? :thinking:

mode 5 lets me go to BusyBox I have no idea what is good for. In this mode, I executed btrfs check /dev/mmcblk0p1 with no error.

Information

  • SN: 61203299630
  • Brand new Turris Omnia
  • In mode 5 the command turris-diagnostics is not available

How much data did you write to the internal memory before you found out the NAS is wrongly mounted? It is possible the internal memory has died if you wrote too much data to it.

Do you happen to have a 3.3V UART cable so that you can debug what is happening?

@peci1 It is a brand new Turris Omnia, I wrote there about 8GB~10GB before it got filled up.

Nope, I have no such a cable.

In mode 5 I executed btrfs check /dev/mmcblk0p1 with no error.

Ok, so if mode 5 is available, try to watch the output of dmesg -w or tail -f /var/log/messages during accessing the web interfaces. Maybe you’ll find some apparent error.

@peci1 Unfortunately, dmesg -w is not a valid command in BusyBox, and there is no /var/log/messages file.

I tried to dmesg with some log level, but it doesn't produce anything during accessing 192.168.1.1`. Even the redirect is not happening.

Still no one? Perhaps @Pepe could help? :thinking:

Are you accessing via http or https? Https was causing similar access problems for some people here…

1 Like

Dear @michalko58, you just made my day. It was exactly that.

I tried to use another browser on different computer and bam, the wizard was triggered.

Edge forced the redirection because I access my other Omnia on the same IP (192.168.1.1) where I redirects to the https version.