Slow opening of websites


I have the TO a few days up and running. One thing that’s really bordering me is that some websites open more or less quickly, others websites take seconds to react.
It’s not the time to load the website but the time between entering a URL and the showing of the first text/picture/add/etc.

After reading on this forum similar complaints/remarks in relation to DNS issues are made although i’m not knowledgeable enough to judge that DNS is the culprit.

I tried using the Google DNS servers ( and and different browsers to improve the response time from websites (like but with very limited improvement. I installed back my old router (Asus RT-N66) and these websites open instantly so i guess its a TO thing.

Does anybody else experience this behavior, is there a fix?


You might have an issue with IPv6.

See [SOLVED] Slow DNS resolution (no forwarding) when WAN is not active


I did not enable IPv6. My ISP does not support it.


I read that forum post. It was to reason why I entered the Google DNS servers.
BTW it made no difference if IPv6 was enabled or not.

Had the same problem… Solved by replacing kresd with dnsmasq:

  1. System - Startup - disable kresd and resolver; enable dnsmasq
  2. in /etc/config/dhcp change option port '0' to option port '53'
  3. Reboot

Hi Amq,

Kresd was already disabled, resolver not.
Dnsmasq was already enabled.

By disabling resolver websites seem to open more quickly now.

Setting Option port ‘53’; how do i do that? Is that something i must do via Putty/Luci?



You need to use SSH / Putty.

Luci : Network : DHCP and DNS : Advanced Settings : DNS server port

You will loose DNSSEC support by disabling kresd resolver and moving to dnsmasq.

Other option is to disable IPv6 either in Omnia or host, or in both. The host or Omnia is most likely doing AAAA record queries for IPv6 and when they fail (timeout) it will fallback to A record queries for IPv4.