Sfp Configuation

username: vodafoneadsl
password: vodafoneadsl

someone has not been updating its default credentials for some time :wink:

1 Like

where i have to insert this config

Go to LuCi/Network/Interfaces. Do Edit on WAN. Select PPPoE as the protocol and apply. In device add eth2.1036 (port 2 with Vlan tag 1036). In username and password enter vodafoneadsl. Save. That’s it. If the module goes, it should connect.

1 Like

Dont forget to

ln -sf /boot/armada-385-turris-omnia-sfp /boot/dtb

It would serve if the cable was not automatically recognized, but this is not the case.

did i configure it right?

Yes but you have to assign this interface to WAN firewall zone so it is highlighted in red not gray

Also from your previous screen we might see that you are using TurrisOS 4.0 its an old and unsupported version. You should first reflash your router with latest version. Or connect the internet somehow and upgrade.

Always go to Network/Interfaces//ETH2/Edit/Firewall Settings and choose WAN as the zone. Apply and save.

And I think in TOS 4.0 eth2 is switch interface not wan so you might have to try eth1 as well

On 4.x already the pattern is what you find in 6.x.

You should post pictures of the Edit board to see if the configuration is correct. One screenshot for each Edit tab. Also try a reboot.

i update the software i configure all the wan staff but still don’t work and now i can’t configure nothing from luci dashboard

Maybe you need to switch dtb to enable SFP as shown by @AreYouLoco in Sfp Configuation - #25 by AreYouLoco
Can you post the output from dmesg in console?

@Davide_Antonica post the output of:

root@router:~# dmesg | grep -E "(sfp|eth2)"                    

so i tried with the help of @lucenera to use the vodafone station as bridge for my internet but it don’t work

So it seems like your SFP is detected. Did you try linking the file in boot and reboot as I mentioned earlier?