Setup script for Nextcloud not perfect, "php-cli" issue


#1

Having TurrisOS 4.0-beta2 in the TO I tried to set up Nextcloud.
I followed
https://doc.turris.cz/doc/en/howto/nextcloud

The 1st step concatenating to auto.lua and package-install seems to work fine, I did not identify issues.

The 2nd step using the script fails. Reproducible.
Is there a debug or log file for it?
I investigated and fount this:

After about 4 minutes with no visible output in the cli the message
“The current PHP memory limit is below the recommended value of 512MB.”
appears. Reproducible.

Unfortunately I did not find out how to extend the mem limit.

I found out the line
“sudo -u nobody php-cli ./occ maintenance:install --database=mysql --database-name=nextcloud --database-user=nextcloud --admin-user=”$ALOGIN" --admin- pass="$APASS" --database-pass="$DBPASS" --database-host=127.0.0.1 --database-port=3306 --no-interaction"
is the step of failure.
It did not state “Installation failed”. It hangs up without notice.

It hangs with no further message and does not come back (at least not within 1 hour).

I verified with the second TO around: 4beta2 and 99% default settings.
EXACTLY the SAME issue.
Bad luck.

Is there a circumvent? (I do not understand this php stuff).

UPDATE: If you leave the script alone for plenty of hours it sometimes finishes (under output of various error messages of type “The current PHP memory limit is below the recommended value of 512MB.”)
May be some improvement is possible.


#2

My experience is that this behavior is mostly because of slow storage. What drive are you using? Isn’t that usb2 or some very slow flashdrive?

That message is just a warning. Mariadb is just a huge beast and their developers require minimal recomended memory that is prety huge. It is just a way of telling you that performance might not be ideal.