Settings for spotify connect


On my previous router (D-Link DIR-868L) I could command my receiver to play music through spotify connect, it also powered the receiver on and off. After replacing the old router with the omnia the receiver is still visible in the overview DHCP Leases and and I can command it using the ip adress in a browser. But any attemp to command it through an app (phone or laptop) fails, the receiver (Arubastr) is present in the list but will not connect. Do I have to set a rule for the receiver to communicate within the local network?

1 Like

I don’t know if there are any default firewall rules for LAN area but I would check that at first. You need to be sure that UPnP or DLNA is not blocked.

or maybe this could help - Chromecast disappears after few hours


Unfortunately, I’m oberserving the same behavior of Spotify Connect applications! The receivers are listed correctly inside the Spotify App, but they do not start the music streaming however.

I’ve turn off the IGMP snooping already. No change! May be a firewall issue? I’m looking forward to any suggestions!

Hi it is strange but more secure this way (I think).
My theory is that the phone connects to the receiver, the receiver communicates with the phone AND spotify server for the stream. The latter (or all) is blocked by the router rules and it would be nice to discover whether this is a “sound” (joke) policy.

It has something to do with DNS. See this thread: Yamaha receiver problem with Knot DNS

1 Like

I have the same problem with my Denon AVR-S720W. In the Spotify app (on Android and on Mac OS X) the receiver is listed, but when I select it, the app displays connecting… for a while but does not connect. Is there a guide to configuring the Turris Omnia to allow Spotify Connect?

Solved! Spotify Connect works now without changing anything on the Turris Omnia.

I manually set my Denon receiver to use DNS instead of, and it worked (after restarting the receiver and Spotify). In order to manually set the DNS, I also had to turn off DHCP, and I just gave the Denon the same IP address that DHCP had given it before.

Hi kslays,

The link from tuomaz cleared everything and the problem was solved by manually setting the DNS in the receiver. I forgot to tag the threath as solved and have corrected that, thnx.