Setting up 6to4 or 6in4

Hey, I am running Turris Omnia through WAN 60Ghz bridge (Mikrotik) point-to-point. My ISP does not provide IPv6 so I briefly tried both 6to4 and 6in4 options. I do have a public IPv4, however 6to4 does not work either if I leave the IPv4 address blank or I fill my public IP into it. Does this mean my ISP is not compatible or does block 6to4?

For 6in4 I don’t quite understand what I need to fill in. Looks like I am required to have some 6in4 provider of some kind who would assign me IPv4 address and IPv6 prefix. Is there any kind of documentation from CZ.NIC about how to set things up? Does CZ.NIC provide similar services? I’ve stumbled upon some legacy documents which I am not sure if they are still valid:


you can use . It’s free and works really well.

I think cz.nic should also work.

1 Like

Out of curiosity, I tried this:

Omnia has the Ipv6 address and a simple: ping6 2600:: works fine from the router. My Windows10 computer though, is not getting Turris’s ipv6 address as default gateway through dhcpv6.

Any hints? I followed the guide in the link above.

Edit: configured through Foris (WAN 6to4, everything works now).