Serial port pinout and baud rate?

I have not been able to get the serial console to work. I think that I want to plug the hacker cable in with the black lead on the leftmost pin (with the LEDs pointing at me), yellow next, orange next, and the rightmost pin open. But either this is incorrect, or I can’t guess the console baud rate–I’ve tried 9600, 19.2, 38.4, 57.6 and 115.2, but I get pretty much the same results with all of these–nothing, or else an unknown character that I suspect is 0xff.

Has anybody actually gotten this thing to work? If so, what pinout did you use? What baud rate?

I didn’t buy the hacker pack but I used a USB to UART that I had for my previous openwrt router. If you check the board where the UART interface header is, you’ll see that it’s labeled “CN10”. Now, if you check the schematics from here:

you can see what each pin is for. Starting from the side where CN10 is printed, they are: 3.3V, RX, TX, GND.

You don’t need 3.3V, just the other three, and don’t forget that the omnia’s RX goes to your adapters TX and vice versa. As for the settings, I used the default 115200 8N1 in minicom, but I had to turn off hardware flow control.

Use the UART header on the bottom right of the board ( leds to the front and to the left of the header). From the left, it’s GND, TX, RX. Speed is 115,200 8N1 XON, XOFF. I’m not using the hacker pack since I’ve got a load of 3rd party UART->USB connectors. Just ensure that the TX from the board goes to the RX of the serial adapter (and RX on the board to TX of the adapter of course). The UART connectors on the big header near the antennas are listed as UART1 on schematics and I only ever got garbage characters out of those. It was nice to see the pop out blanking plugs on the antenna side to run the console cables through. Saved getting the Dremel out :wink:

How to connect the serial cable in the hacker perk:

Thanks, everyone! The bit (!) I was missing must have been 8n1–as soon as I set that, it worked.