Samba share doesnt show up in windows 10

im new to windows 10, used to have windows 7. from there TO local network samba share worked out of the box.

TO version is 3.11.7

in windows 10 i havent changed things.

when trying to map network share manually (\\openwrt\share) to a letter it pops out an error:

error message


The mapped network drive could not be created because the following error has occurred:

You can’t connect to the file share because it’s not secure. This share requires the obsolete SMB1 protocol, which is unsafe and could expose your system to attack.

Your system requires SMB2 or higher. For more info on resolving this issue, see:


Samba USB Disk not showing in Windows 10 this did not fix my problem.

when connecting via mobile with openvpn i can see the samba share without a hassle. with windows 7 everything worked ok.

i have network discovery on and i can see my printer and so on.

what is wrong? at least samba service is running etc because its working via openvpn with mobile.


You should add support for smb1 in windows.

1 Like


however is this solution secure or is smb share feature afterall “not recommended”?

if and when smb1 is not secure what is the second best / easiest way to achieve similar share system between turris omnia and win10 (that works with openvpn,too)

You can try setting min protocol to smb2 in the samba config

installing smb1 client to w10 gave me access to network share by TO.

adding following lines to samba conf however didnt give access to the share

additions to smb conf

client min protocol = SMB2
client max protocol = SMB3

so what is wrong? is enabling smb1 still only option? that sounds weird.

Client min protocol refers to the smbclients on the omnia itself. Try server min protocol instead

wsd is the solution they plan to use on freenas, and i see a wsdd2 package exists its worth a shot to see if that works

Show us your samba config

now i see “turris” in the network but its not accessable. im not familiar with wsdd. how it should be configured?

im pretty sure that it is not the prettiest one but worked in w7

samba config

netbios name = |NAME|
display charset = |CHARSET|
interfaces = |INTERFACES|
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
server min protocol = SMB2
server max protocol = SMB3
browseable = yes
create mask = 0644
directory mask = 0755
force user = someuser
syslog = 10
encrypt passwords = true
passdb backend = smbpasswd
obey pam restrictions = yes
socket options = TCP_NODELAY
unix charset = ISO-8859-1
local master = yes
preferred master = yes
os level = 20
security = user
null passwords = yes
invalid users = root
smb passwd file = /etc/samba/smbpasswd

Ok, openwrt package doesnt work with SMB3 yet, make server max protocol = SMB2 and you will got it working after restart.

changed that. min and max is now smb2. i even rebooted TO. but i cannot get the share visible without installing smb client 1.0 on w10.

Remove the server max and min, and add folowing:
min protocol = SMB2
max protocol = SMB2
client min protocol = SMB2
client max protocol = SMB2

As for security of SMB1: with samba 4.11.0 SMB1 will be deprecated and disabled by default because it has known security problems:

You might also want to add these options:

    server signing = auto
    client signing = auto
    smb encrypt = auto

It could also be an anti virus software interfering. Some are known to always downgrade the connection to SMB1.

You do realize that min protocol is a synonym for server min protocol, from the manual

Smb2 does not do the network discovery like smb1 does. So the lack of visibility without installing smb1 on windows is to be expected.


found that during this problem, thats why installing smb1 client to w10 sounds bad solution.


that was a new information to me. thanks!

restarted samba service from luci. and it works now!

not sure which of these lines here did the job but maybe afterall post #12.

let me know.

thanks guys!