Samba not working without internet

Hi, did you noticed, that Samba is not working when internet connection is down? (Omnia, HBS 5.1.4)

I have tried solution from this link (add router ip to resolv.conf), but it did not helped:

Do you have some other advice that will make it work while internet is not working?

Nobody else had this problem? :roll_eyes:

Could you share a bit more information on how “doesn’t work” manifests? Assuming you’re using the router’s hostname to connect to it, does DNS resolution work while you’re offline?

I ahve noticed it while there was modem failure and I was trying to use VLC on TV. There was almost infinite loading of samba folders. When internet is working properly, samba works fine too.

If you mean under DNS resolution that, I can reach router after entering its IP, then yes, that is working even offline.

Is VLC using the IP address or the domain name to access the Samba share?

If it’s the domain name, can you try to resolve it using a PC while you’re offline, e.g., nslookup your-hostname.your-domain?

I don´t know what is using VLC on AndroidTV. I have only basic Samba settings, so I think it is only IP. I think VLC is scanning network for network folders, which it remembers from “online” times, so it was trying to reach them, but it took about 5 minutes to show them. And when trying to dig deeper into folder structure it took very very long…

And I remember that TV displayed warnig about disconnected Ethernet network. I have tried to plug and unplug ethernet cable, restart TV and Omnia, but nothing helped. Even disconnecting from electricity.

I’m afraid we won’t get far in terms of troubleshooting based on such sparse information. You could try to access the Samba share from a PC and try to reproduce the issue there – this should allow for better troubleshooting than on the TV.

Besides that you could think about going back to TOS 3 for the time being if it worked better for you. Using schnapps this should be quite easy.

TOS 5 is pretty fine (installed from medkit, so no update from TOS3), internet is working 99,95% of the time. But, this Samba bug is known all over the internet as I have noticed and still not repaired… I have noticed it only due to modem failure at my parent´s and then tried it at home with the same results.

I don´t know if I am doing this right, but NSlookup in LuCI returns this for (no matter if online or offline):


        ** server can't find NXDOMAIN

My Samba settings are:

config samba
	option workgroup 'WORKGROUP'
	option charset 'UTF-8'
	option description 'TurrisNAS'

config sambashare
	option path '/mnt/sdb1'
	option create_mask '0666'
	option dir_mask '0777'
	option read_only 'no'
	option guest_ok 'yes'
	option name 'Serialy'
	option force_root '1'

config sambashare
	option path '/mnt/sdc1'
	option create_mask '0666'
	option dir_mask '0777'
	option read_only 'no'
	option guest_ok 'yes'
	option name 'Filmy'
	option force_root '1'

Now I have test it on TOS 5.1.5

Results - network share is inaccessible from PC (Win10) and from VLC too when offline. After getting online everything works fine.

TV is yelling that cable is disconnected, but when I hit “details” it says cable is connected.

VLC network is showing devices connected to network:

But after clicking on Turris - there is only “loading”…

In VLC settings, there is only one thing about network about preffering SMB1, but it has no impact on function.

And now I have noticed, that editing file /etc/resolv.conf is useless, because it gets default values after every restart…