Routing throughput seems to max out at about 350mbps

Can the Turris Omnia handle internet connections faster than about 300 to 350Mbps?

I recently upgraded to gigabit connection and if I have my computer hooked up directly to the modem I can get about 600mbps download, but if I’m connected through the omnia, it maxes out at about 350mbps.

Is the hardware in the omnia not able to handle routing at more than about 350mbps? If it can handle more than 350mbps, are there some settings or tweaks I have to do for it to achieve higher throughput?

I don’t have anything fancy configured/enabled. Basic out of the box setup with just a few static dhcp/IP assignments defined. Not using WIFI as I have external access point.
All tests were done via hard wired connection.

Yes, according to its hardware specifications:

  • WAN SFP port 2.5 GbE
  • WAN metal port 1 GbE
  • LAN 1 GbE

The O should be able to match the modem throughput sans factors that could impact the outcome:

  • modem being a sole modem or some modem-router combo with packet processing/scheduling (NAT/firewall/SQM/QoS/IDS?
  • modem in bridge mode?
  • ISP upstream connectivity (e.g. cable, fibre, PPPoE, ipv4 | ipv6, dual stack | ds-lite, etc)
  • additional packet processing on the O (e.g. SQM/QoS, IDS, Pakon)?
  • any other bandwidth consuming acticity on the network during the throughput benchmarking (e.g. streaming, file sharing)
  • methodology of throughput benchmarking

Probably requires to find the bottleneck in the first place in order to take appropriate steps. If you are comfortable with cli on the O:

  • netmetr (simple up/down-load throughput benchmarking)
  • speedtest --mini (simple up/down-load throughput benchmarking, requires python app speedtest-cli to be installed)
  • wget -O /dev/null (simple download throughput benchmarking)
  • curl -o /dev/null (simple download throughput benchmarking)
  • mtr -zrbw (packet path analysis, requires OS package mtr to be installed)

More elaborate throughput benchmarking with OS apps like netperf | iperf3 or python app flent

Modem is a Netgear CM1100. It’s a pure DOCSIS 3.1 modem, no router and no configuration for bridge-mode etc as that’s the only mode it runs.

I have not setup any additional packet processing. Everything on the Omnia is basic factory out of box with exception of me defining some static IP for devices on the network.

No other device on network while testing, Everything unplugged except the computer doing the test.
Testing using app.

I have not done anything in the cli so not even sure where to start.

1 Like

You would need to connect to the O via ssh. netmetr is also available via the Foris web interface.

I logged into the Foris web interface but didn’t see netmetr

Thought it comes installed by default, like in the demo [1]. If not check that is selected in the package list [2]

Annotation 2020-04-20 225505


Thanks, looks like it was not installed. I installed it and ran a few tests. download speeds were between 110 and 160mbps, uploads at 22mbps and latency 170.

When I run speedtest app, downloads typically range between 300 to 350mbps, uploads 30 to 40mbps and latency in the 13-15ms range.

So running netmetr test is even worse.

I am not familiar with the DOCSIS 3.1 technology and how the modem handles the packet pass-through. The issue seems a bit like a potential bufferbloat [3] which is more commonly observed in xDSL connectivity however.

Though it is curious that the computer client does not exhibit the issue. If TOS3.x is running in the O then it is rather outdated, kernel as well userland, and more contemporary version may remedy the (performance) matter.


From what I can see, netmetr test isn’t talking to a server local to me. So that may explain the low bandwidth and high latency. uses local servers (usually within 50 miles or so).
I ran some more tests and it’s pretty consistent.
Direct to modem : 550-650mbps download, 35-40mbps upload, 12-15ms latency
Through Omnia: 300-350mbps download, 30-40mbps upload, 13-15ms latency
netmetr test in foris: 100-160mbps download, 22mbps upload, 160-180ms latency

Aside from the OS on the O the cause could be also some hardware defect. Support/diagnostic (procedures/channels) from the manufacturer is outlined here [4]


Try Omnia handles north of 500 mbits on cable (same modem btw) no problem.

Did some testing through
Through Omnia, I saw a range of 440-230mbps. Average of 50 runs is 370mbps.
Directly connected to modem, saw range of 780-520mbps. Average of 50 runs is 710mbps.

So still seeing about 50% reduction when going through omnia.

That with TOS3.x or TOS > 4.x?

This thread [5] mentions various mvneta performance related patches that are likely not backported to TOS3.x (did not check the repo)

[5] Can't get 1Gbit on Mox Classic - #45 by neheb - MOX HW problems - Turris forum

Currently showing it’s running Turris OS version 3.11.16

How do I get 4.x? It’s set to auto update, so I thought it’ll always download and install the latest OS.
I get email notification every once in a while that it has updated and will reboot late night.

Please see

1 Like

I’m on 4.x HBS. Use medkit to install latest, it’s the easiest method.

You shouldn’t see any performance drop with Omnia. How is your cabling?

Tested with multiple CAT 5E and CAT 6 cables. Used the same cables when testing directly connected to the modem.

Have you activated Pakon in the Foris interface? This one is known to cause issues on fast internet connections.


Looks like Pakon was installed. I uninstalled it and ran some more tests. was still about the same range, 280-440mbps with average in the 370mbps range. was significantly faster, Saw peaks in the 900mbps range, with average over 50 tests at 830mbps.
Directly connected to the modem saw peaks at 970mbps with average of 50 runs at 950mbps.

So now throughput through Omnia (at least with is very close to direct connection to modem.


I will wait for the 5.0 OS auto update to get pushed out.