Routing between vlan

Hello,

I plan to reconfigure my network and currently search and aggregate informations.
My final goal is to connect a local DMZ to my existing Wireguard VPN.

The configuration will be :

  • Remote servers connected with Wireguard to serve an internal VPN (don’t plan to use is as remote internet output) (10.20.2xx.0)
  • A local Wireguard to serve the VPN
  • 2 local LANs to have a domestic network (can connect to VPN/DMZ and internet, 10.10.100.x) and a DMZ (can connect to Internet and VPN but not domestic network, 10.30.150.x)

Currently I find the tutorial for Wireguard : https://doc.turris.cz/doc/en/public/wireguard
Some information for VLAN : https://doc.turris.cz/doc/en/howto/vlan_settings_omnia to add yet (I don’t fully understand how it’s work to add the second VLAN to the interface)

But I don’t find information to configure second VLAN (current with the default configuraiton port) to allow routing and configure the interface (with a specific IP network)
Current configuration :
config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals 'globals'
	option ula_prefix 'xxxxxxx:xxxxx'

config interface 'lan'
	option ifname 'eth0 eth2'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.10.100.xx'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option peerdns '0'
	option dns 'xxx.xxx.xxx.xxx'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option noserverunicast '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6'

Currently I have only “LAN”, “WAN”, “WAN6”.
Software version 3.11.19.1

So, did I think in the good way ?
How to define custom routing between interfaces/VLAN ?
Any information to achieve the goal is welcome.

Thank you.