Resolver neglecting settings from its config

Turris Omnia - rtrom01
Turris OS 3.9.6
Kernel 4.4.119-082ea0f4a4e204b99821bedcb349ed54-0
Unbound 1.6.8

Either the neglience resides in parsing the settings at all or in the output of the parsed unbound.conf

Assuming that all below, which been added in the “config resolver ‘unbound’” section of /etc/config/resolver, can be parsed by uci

option dhcp_link ‘dnsmasq’
option logfile ‘/data/log/unbound.log’
option so_sndbuf ‘4m’
option so_rcvbuf ‘4m’
option so_reuseport ‘yes’
option cache_max_ttl ‘14400’
option ssl_upstream ‘yes’
option rrset_roundrobin ‘yes’
option module_config ‘validator iterator’
option ratelimit ‘150’
option hide_identity ‘yes’
option hide_version ‘yes’
option hide_trustanchor ‘yes’
option use_caps_for_id ‘yes’

There are no errors when
/etc/init.d/resolver restart

However none is showing in the output of unbound.conf

Tried all/any in the unbound syntax (e.g. rrset-roundrobin: yes) through

list include_path "/etc/unbound/unbound_srv.conf"

but that is just throwing

error: syntax error

These options aren’t available in Turris uci config so you have to use include file and place their unbound version under server clause (see documentation

@paja thanks. Mentioned in my initial post that I tried and it is not working as described

Could you send your config file ? I tested it with this file and it works without error.

Content of file /etc/unbound/unbound srv.conf:

	rrset-roundrobin: yes
1 Like

Argh, I spotted the issue… me ignorant… :face_with_symbols_over_mouth:

Missed the server: clause apparently

Is there some documentation which option can pass through uci directly and which have to be coverted?