Remote log - how to configure

I’ve configured Omnia logging to my Synology server see part of system.conf
> config system
> option timezone ‘CET-1CEST,M3.5.0,M10.5.0/3’
> option zonename ‘Europe/Prague’
> option cronloglevel ‘8’
> option log_proto ‘udp’
> option hostname ‘router’
> option log_ip ‘’
> option conloglevel ‘7’

But the this doesn’t work. What is wrong? My previous router 5 years old Asus could log without any problem.

Perhaps the typo in last line
option conloglevel ‘7’
-> should be
option cronloglevel ‘7’

Hope this helps
Greetings Toking

I don’t know how logging works in default OpenWrt, but Omnia seems to use syslog-ng. I also tried to enable logging in LUCI, but no luck. There was no syslog-ng configuration created.

So I created a new file /etc/syslog-ng.d/remote.conf with the following content:

destination d_loghost { udp(""); };
log {
#       filter(f_turris_iptables);

After reloading syslog-ng I’m receiving the logs over the network now.

BTW according to, conloglevel is a valid option. :wink:

@chrosik Wasn’t aware of this. Thx for showing me my mistake. It’s always a chance to gain more experience

Part of the startup script for syslog-ng should take the settings from /etc/config/system and create an appropriate file in /etc/syslog-ng.d/.

Since the decision is to use syslog-ng by default, tying the config into that should be done by default.

Omnia luci has broken support for remote syslog configuration. Data entered in UI is not used anywhere. It is only stored in UCI database but NEVER pushed into appropriate syslog-ng config.

This should be bugreported I guess … and here it is: