Region Setting failure for America Indianapolis

I tried to set the region setting to Indianapolis, and got a failure:
ValueError('too many values to unpack (expected 2)',). I used Detroit instead, and that worked fine, so I think it’s a bug with Indianapolis.

See below stack:

ValueError('too many values to unpack (expected 2)',)
Stack trace
Traceback (most recent call last):
  File "/", line 93, in __call__
  File "/", line 86, in __call__
  File "/", line 68, in __call__
  File "/", line 979, in __call__
  File "/", line 954, in wsgi
  File "/", line 862, in _handle
  File "/", line 682, in mountpoint_wrapper
  File "/", line 979, in __call__
  File "/", line 954, in wsgi
  File "/", line 862, in _handle
  File "/", line 1740, in wrapper
  File "/", line 92, in wrapper
  File "/", line 79, in wrapper
  File "/", line 163, in config_page_post
  File "/", line 136, in save
  File "/", line 61, in save
  File "/", line 235, in save
  File "/", line 261, in process_callbacks
  File "/", line 323, in region_form_cb
ValueError: too many values to unpack (expected 2)
 'CONTENT_TYPE': 'application/x-www-form-urlencoded',
 'DOCUMENT_ROOT': '/www',
 'HTTP_ACCEPT': 'text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9',
 'HTTP_ACCEPT_ENCODING': 'gzip, deflate',
 'HTTP_ACCEPT_LANGUAGE': 'en-US,en;q=0.9',
 'HTTP_CACHE_CONTROL': 'max-age=0',
 'HTTP_CONNECTION': 'keep-alive',
 'HTTP_COOKIE': 'available on request',
 'HTTP_DNT': '1',
 'HTTP_HOST': '',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) '
                    'AppleWebKit/537.36 (KHTML, like Gecko) '
                    'Chrome/84.0.4147.105 Safari/537.36',
 'PATH_INFO': '/main/time/',
 'PATH_TRANSLATED': '/www/main/time/',
 'REMOTE_PORT': '50010',
 'REQUEST_SCHEME': 'http',
 'REQUEST_URI': '/foris/config/main/time/',
 'SCRIPT_FILENAME': '/www/foris/config',
 'SCRIPT_NAME': '/foris/config',
 'SERVER_PORT': '80',
 'SERVER_SOFTWARE': 'lighttpd/1.4.54',
 '': <bottle.Bottle object at 0x26960f0>,
 'bottle.raw_path': '/time/',
 'bottle.request': <LocalRequest: POST>,
 'bottle.request.body': <_io.BytesIO object at 0x27f1c00>,
 'bottle.request.headers': <bottle.WSGIHeaderDict object at 0x2805160>,
 '': {'country': 'US',
                         'csrf_token': 'available on request',
                         'how_to_set_time': 'ntp',
                         'region': 'America',
                         'send': '',
                         'zonename': 'America/Indiana/Indianapolis'},
 'bottle.request.urlparts': SplitResult(scheme='http', netloc='', path='/foris/config/main/time/', query='', fragment=''),
 'bottle.route': <POST '/<page_name:re:.+>/' <function config_page_post at 0x25b79a0>>,
 'foris.backend': MqttSender('localhost:11883'),
 'foris.language': 'en',
 'foris.session': <foris.middleware.sessions.SessionForisProxy object at 0x28697b0>,
 '': {'_messages': [],
                        'csrf_token': 'available on request,
                        'user_authenticated': True},
 '': 'available on request',
 'foris.version': '100.5',
 'route.handle': <POST '/<page_name:re:.+>/' <function config_page_post at 0x25b79a0>>,
 'route.url_args': {'page_name': 'time'},
 'wsgi.errors': <flup.server.fcgi_base.OutputStream object at 0x280a7c0>,
 'wsgi.input': <_io.BytesIO object at 0x27f1c00>,
 'wsgi.multiprocess': False,
 'wsgi.multithread': True,
 'wsgi.run_once': False,
 'wsgi.url_scheme': 'http',
 'wsgi.version': (1, 0)}

I downloaded the error report as instructed, and can provide on request.


As instructed there is that you should send it to with the description which leads to this error, but there isn’t anything to share it on a forum, right? :wink:

I see that this error is fixed in Foris version v100.7, which is available in Turris OS 5.0+ release. This fix does not make it into Turris OS 3.x and we will see if it is possible to backport it there as Turris OS 3.x is in maintenance mode. More details:

OK so I need to upgrade my Turris OS?