reForis Shield package is not available on Turris Omnia (Solved)

Why can’t i update OS ?

Blockquote -----------------------------------------------------
TurrisOS 5.2.7, Turris Omnia

root@turris:~# pkgupdate
INFO:Target Turris OS: 5.3.0
line not found
line not found
line not found
line not found
line not found
inconsistent: Requested package reforis-shield that is not available.


Hello @Titanet,

On Turris Omnia, you should not have an even simplified version of reForis, especially which was for Turris Shield, than it comes in our other devices.

There are two possibilities:

  1. You installed the package yourself.
  2. You flashed the wrong medkit even though it should not be possible, and even if you somehow do it, it will be alright as some other precautions will prevent you from having it and during the next update, it will be a normal router instead of router which has more preinstalled packages based on the contract.

But this is everything based on my guess since we don’t have anything useful in your report. Unfortunately, there is only that the router requested package reforis-shield, which is true. It was removed in Turris OS 5.3 version as it is no longer necessary as normal reForis support device modes.

It would be helpful to generate diagnostics and send it to our support department. From the logs, we can know how and why the package was requested and provide you with ways how to remove it from requests.

Thank you for your answer. Yes, I contacted the support for this problem and the solution was to remove this package “reforis-shield”. Then the update was done correctly.


Mark your post as solved.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.