reForis error using hostname URL

I was configuring Wi-Fi in reForis using the hostname URL https://turris.local but saving the settings resulted in a unknown error message being displayed.

2023-03-20 21:01:18: (../src/server.c.1588) server started (lighttpd/1.4.67)
2023-03-20 21:20:28: (../src/gw_backend.c.528) connect /tmp/fastcgi.turris_auth.socket-0: Connection refused
2023-03-20 21:20:29: (../src/gw_backend.c.528) connect /tmp/fastcgi.reforis.socket-0: Connection refused
2023-03-20 21:20:32: (../src/mod_fastcgi.c.450) FastCGI-stderr:[2023-03-20 21:20:32,367] WARNING in flask_seasurf: Forbidden (CSRF token missing or incorrect.): /api/wifi

Doing the same operation using the IP URL worked perfectly!

Note: it was a freshly installed Omnia with Turris OS 6.2.4, re-flashed with the latest medkit.


This is unfortunate that the error does not reflect underlying problem. The schema for this change does not allow you to use . dot in hostname. The definition looks like this

There is no dot in hostname!

# uci show | grep hostname

I can access reForis, authenticate, explore and change the configuration using both URLs: http://turris.local and However, when saving Wi-Fi settings the reported error is produced.

Sorry, that is dumb. I’ll try to replicate and get back to you again.