Recording TV with TVheadend on turris/openwrt - here's a setting tweak to be able to successfully save recordings

If you’re using TVheadend with a USB TV adaptor,using default settings, recording video doesn’t work and ends up buffering video in RAM until it runs out of memory. It doesn’t end up creating any recording files and it is completely unobvious why it isn’t working.

The way to solve this is to go into the Configuration/Records/Digital Video Recorder Profiles/Default profile and then go down to the Filename character set option and change it from ASCII to UTF-8 and then restart.

2 Likes