Radio Streaming Problem - DNS?

The problem: I have a Bluesound system including radio streaming which will not retain a stream for more that a few seconds without dropping the connection and then a few seconds later, reconnecting and then dropping etc. I have read every possible forum article and found a similar issue with a Yamaha streaming device. My problem relates largely to BBC streaming (particularly Radio 4). I have tried various different quality streams but all have the same problem.

From what I can understand, the issue seems to be the inability to change the Knot DNS system or to change the set DNS servers. I note that a more recent thread has addressed this inability to change the DNS configuration but in terms which only a die-hard OpenWRT expert would be expected to understand. NB I have tried all available combinations of the DNS settings page.

The way forward for me??: I am NOT an OpenWRT expert and when I purchased this router I did so because it was open source and secure. There was no additional requirement attached that any owner had to “get his hands dirty” and go behind what seems to be an extensive GUI, in order to change basic configs such as DNS settings!

No other router I have tried has any problem at all with streaming - I have tried an Edgerouter x, ASUS and an old TP-Link.

Please could someone explain to me how, in reasonably simple terms, I can change the KNOT DNS which, from what I have read, is probably / possibly the root cause. I am happy to use Putty / SSH so long as I know what to enter!

Any thoughts / suggestions / assistance would be greatly appreciated. Otherwise sadly this router will go back into it’s box where it has resided for most of it’s life because of this issue.


I’m writing all of this assuming that DNS is the problem, like it was for the other “smart” devices. Side note: even if I try hard, I can’t consider it a “mistake” of knot-resolver, as even though the behavior is different from most other implementations on this, all is perfectly within standards.

The least-impact workaround is in this post: Yamaha receiver problem with Knot DNS It changes the DNS provider for that particular device to Google’s public servers; you may want to put your ISP’s servers instead, for example. I believe editing files is easy enough through putty (or maybe winscp).

Future Turris will contain versions that will no longer exhibit this difference, but I can’t personally promise when that will happen: Garmin products unable to use Wifi despite IP address attributed