Problems with lxc - Can not create container from GUI

Hello again. I am on Version 3.9. (Turris Omnia)
First thing, i can not create any new LXC Container from Luci, there is no failure message.

2nd LXC problem: still lxc-create -t download -n archlinux does not work and end with: tar: Ignoring unknown extended header keyword ‘SCHILY.fflags’

3rd LXC problem, most times i try to start a container after creating it, it will not start. (not any message in a log file)
also i can not login into luci, i have to “reboot -f” the router.

i first tried to remove and install LXC - did not work.
I did a factory reset! did not help. (3 LED)
i also did a reset with new Firmware (4 LED)
Still same problem. Anyone got a good hint? - Need any other information?

I confirm
In version 3.8.6 Turris OS is the same.
Cannot stop/start LXC conteiner from luci and can’t create new conteiner

thanks for confirming - the arch linux problem, thats the problem with the lowest priority.
ofc there will not help factory reset.

at this moment i have to reboot the router every time i started a single container.
and it does not make any difference if the container start or not.

which service i could restart, so i do not have to reboot the router all the time.

my list is not empty, i can choose every single template

i can not login into luci/foris anymore, after trying to start a container a 2nd time.

also i can not start any other container. its will end with:
lxc-start 1513237309.523 INFO lxc_start_ui - lxc_start.c:main:264 - using rcfile /srv/lxc/alpine/config
[details=Summary]This text will be hidden[/details]lxc-start 1513237309.523 WARN lxc_confile - confile.c:config_personality:1077 - unsupported personality ‘armv7l’

internet, wlan, routing, dhcp,… everything else is still working, except webserver (foris/Luci) and the lxc part

thanks, already tried this some times
restarting lighthttpd does not help, service is shut down, and does not make any output on starting again.

fast did a capture of my screen, maybe this shows the problem(s)
Sorry, just a fast capture without much thinking, but if it helps?!

did you move your lxc folder out of /srv/ and link it back? This was the problem for me. Use the container config file instead:
lxc.rootfs, lxc.mount.entry

Do i need any other permissions?
I just removed and created /srv/lxc new.
i created a new container called alpine again.
i can start it one time and stop it one time.
Next time i start, it will “crash” like before (check video)

root@turris:~# ls /srv/ -alh
drwxrwxrwx    1 root     root           6 Dec 13 17:48 .
drwxr-xr-x    1 root     root         126 Dec 13 17:34 ..
drwxrwxrwx    1 root     root          58 Dec 14 12:17 lxc

On my system (I did’nt touch the folder) it’s slightly different but this schouldn’t be the problem.
root@turris:~# ls /srv/ -alh
drwxr-xr-x 1 root root 6 Dec 13 12:02 .
drwxr-xr-x 1 root root 126 Dec 13 13:48 …
drwxr-xr-x 1 root root 60 Dec 14 13:33 lxc

On my sytem it does not work if I try to use a (ntfs) usb hdd as storage, also when used for lxc.mount.entry. After removing the lxc.mount.entry everything works.

I have a similar problem starting containers. I have 2 Ubuntu containers, one with Pi-hole and another with Nextcloud, that i can stop fine, but when i try to start them with lxc-start or even reboot them with lxc-stop -n container -r, they just hang there, doing nothing and slow down the system to a crawl. When I go to Luci lxc-containers to check the containers, it’s empty, as if i had no containers. Rebooting the turris omnia starts the containers just fine, and the system will start to work as expected, until you try to restart a container again.

Exactly the problem i’ve got!

Same problem on my end. Latest firmware, I cannot create an lxc-container via the GUI. My two existing container start fine, can be restarted, auto start when rebooting.

We know that you can’t create LXC containers via LuCi.

Rather stay with containers URL, which points to, but as workaround you are unfortunately forced to install them via SSH.

Whups, sorry about that, I was too lazy to go through all posts here, so my seemingly “dumb” question. :sweat_smile: Thanks.

Maybe the heading is not clear, but this is not the main problem.
I (maybe we) can not work fine with containers anymore.
i can not restart container. (2nd start will fail)
i can not do work with luci, after it fail, i have to reboot the router.
i can not create a new container after a while the router is running. (ssh)
(i have to restart the router) after fresh start i can create container and start it one time.
please check the video and the posts before, thanks in advance.

1 Like

Same symptoms reproducing here…

This behavior has been manifesting itself here for quite while now (I do not think it is recently introduced).

I’m hoping for a knowledgeable person to pick this one up, as I tried everything in my book (to no avail) and my lxc-containers are mission critical… :sweat:

Hello guys, my router has the same issue, @Pepe gave me a sort of solution, although I’m not entirely satisfied with it…

If under the LXC Containers page (LuCI), you change the containers URL from to -> it will work… I tested it and yes! the container is created under the GUI.

Why am I not satisfied…? Well, if you compare the templates list once you save & apply the changes, you will notice that under api.turris… the number of templates available is smaller, and the templates versions are older…

Give it a try and comment back…

you are right, Ihave the same problem. Maybe we should create a new thread with an approptiate subject?

Apparently containers can be started once and then all of them at once. After that, any restart cuases the described freezing.
If they are not started literally at once, only one container can be started, the second causes the freezing.

Hello Martin and everyone else who think you got the same problem like:

please confirm my and your problem here: