Problems updating from 4.0.1 to 5.2.3


A couple weeks ago I got a Turris Omnia 2020, and took quite a while to setup everything the way I wanted. Made a mistake along the way, and decided to do a factory reset(Holding the button until 3 leds were lit). Setup everything again, taking another considerable chunk of time, and decided to update to the newest version.

But after issuing the update from the web interface, after the reboot the router has no web interface, and no ssh connection. Internet still works, so it kept my configuration. I rolled back to a snapshot holding the button until 2 leds were lit.
Running pkgupdate from ssh gives the same result, but prints the following messages:

sure enough, it is removing a bunch of stuff, including openssh-server.
opkg update also doesnā€™t seem very happy:

How can I update my router? preferably without loosing all my configuration a second time.
Thanks for any help.

1 Like

Hey, check this issue: Update from 4.0.1 to 5.2.2 disables WebUI and SSH.

1 Like

Hi there. Yesterday is was fiddling with wireguard, and this nOOb completely trashed his 2016 Omnia 5.2.4 :slight_smile: . So i had to factory reset it, back to 3.x.
Then i tried the software update option to go to 5, and that also went totally bananas. Lockup, again factory reset.
Then i ( finally ) decided to use some old usb stick, put the latest medkit Index of /hbs/medkit/ on it, stick it in the frontal USB of the omnia, press the reset button till 4 leds are on, release reset button, and 3 minutes later i had 5.2.4. Yes, you loose all your settings, but this is by far the most simple way to flash your router if you are on 3.x or 4.x imho.
And if you factory reset it now, it goes back to 5.2.4.

1 Like