Problems to access NAS

Dear community. I have followed the following guide Home NAS [Turris wiki] to set up a home NAS on Turris Omnia. The only exception is that I have an encrypted external usb drive that I have to manually decrypt after every reboot. Still when I try to access it from Gnome (after decrypting) Files by smb://192.168.1.1/WDNAS I get the error “failed to mount windows share connection refused”.
I am on Debian Bulls-eye and Foris 5.3.3
The guide I followed claims to be only for Turris Os 3.X but in the current manual there are no NAS instructions.
Kind regards

Can you be more specific? Are you using external hard drive connected to USB? What is your configuration?

Ok, @viktor thank you for your reply. Yes I am using a USB 2.0 external drive that is connected to the front USB port. I configured the NAS using the GUI as described in the guide mentioned above. lsblk shows me that the drive is mounted:
sda 8:0 0 931.5G 0 disk
└─sda1 8:1 0 931.5G 0 part
└─WD 252:0 0 931.5G 0 crypt /mnt/WD
The browser gives me error “404 not found” when I try to acess the NAS via the adressbar.
Best

“404 not found” is web browser error. SMB protocol is different. Try mount your shared folder via command line. Can you also share your related configuration files?

I mount the drive manually via the command line. And I also noticed that “samba” was not enabled. So now after enabling samba the disk shows up in the Gnome window manager “Files” under “networks”. I can enter the hostname folder but when I try to open the drive I now get the error message “Failed to mount Windows share”. Software caused connection abort." @viktor what configuration files are relevant and do you know where they are located?

What command you used?

Enabled does not mean running.

/etc/config/samba

My friend helped me to set up a little script to mount the encrypted drive. It looks like this:
cryptsetup open $(blkid | grep UUID | cut -d: -f1) WD
mount -a
UUID here is the beginning of the UUID
And I can see with lsblk that it is mounted:
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 931.5G 0 disk
└─sda1 8:1 0 931.5G 0 part
└─WD 252:0 0 931.5G 0 crypt /mnt/WD
And this is what the samba status looks like in Luci:


Do you mean it is not running with this status?
I found two samba config files samba:
config samba
option name ‘OpenWrt’
option workgroup ‘WORKGROUP’
option homes ‘1’
option description ‘WDNAS’

config sambashare
option browseable ‘yes’
option name ‘WDNAS’
option path ‘/mnt/WD’
option read_only ‘no’
option guest_ok ‘yes’
And samba 4:
config samba
option workgroup ‘WORKGROUP’
option charset ‘UTF-8’
option description ‘WDNAS’

config sambashare
option path ‘mnt/WD’
option name ‘WDNAS’
option create_mask ‘0666’
option dir_mask ‘0777’
option read_only ‘no’
option guest_ok ‘yes’
Maybe these two are in conflict?