Problem with Google

Any services of Google ( Gmail, Youtube, Google ) don’t work. After reboot the router is all OK, but only few minutes.


Sorry for the Czech link, the problem is with several ISPs who do not validly DNS settings, please try the procedure below.

1 Like

googe services works only few minutes after omnia restart

Same here.

root@turris:~# nslookup
Address 1:

nslookup: can’t resolve ‘’: Try again

after reboot:

root@turris:~# nslookup
Address 1:

Address 1:
Address 2: 2a00:1450:401b:802::2003

when I use CZ.NIC DNS the problem is still here:
root@turris:~# nslookup
Address 1:

nslookup: can’t resolve ‘’: Try again

with disabled dns sec everything works correctly … provider is

Same here - all google services return an dns error, with disabled dnssec it seems to work fine. Omnia is up to date, provider is o2.

I setup DNS to, Switch ON forwarding ( foris>DNS>forwarding) and all is OK.
If Google services is off, I test DNS connection in Foris and it is go. No reboot needed.


I wonder if it’s a regression in knot (it was part of the update), I’ve seen the same.

Same here, no google services. Disabled dnssec in foris and it works now. Problem happens since the last 3.6.2 update
I’m on Orange in Belgium

Hmm disabled dnssec but the problem seems to return.

Can’t seem to google translate the page in Czech (even when the services still worked)

Update: using google DNS solves the problem, but I don’t feel like setting this in all my devices
Any english tutorial on how to solve this permanently?

Update2: Rebooting turris seems to resolve the issue so far (with dnssec disabled). 35 minutes uptime and google services still working

Same issue here, UPC, Czech Republic. It’s definitely the Turris as it started with last update and its happening on various ISP’s across different countries.

I’ve found that not just restart solves it for few minutes, but also when you go in Foris GUI to DNS and reinitialize the test. It immediately starts to work for some minutes.

1 Like

For now, it seems like knot is the culprit. You can revert to previous version by adding this code to /etc/updater/user.lua file:

Repository 'turris-archive' '' {
        priority = 40,
        ca = "file:///etc/ssl/updater.pem",
        crl = "file:///tmp/crl.pem",
        pubkey = "file:///etc/updater/keys/"
Install "knot-resolver" "knot-libknot" "knot-libzscanner" {repository={"turris-archive"}}

But please check in few days if we released the update and if so, remove added code to get the newest version.

Edit: Sorry and of course run

1 Like

@cynerd thanks for the info, I’ll just wait for the update in a few days.

Many thanks
Update: I did nothing with my omnia and google down again :frowning: , Restarting

I also have these problems.

It’s not needed anymore to say “+1” or “I have also this problem”. It was confirmed that this is caused by last update.
Official workaround for this problem is above your post or you can wait for another update.

1 Like

Can somebody who can reproduce this issue enable debugging by setting the following in /etc/config/resolver:

config resolver 'kresd'
        option log_stderr '1'
        option log_stdout '1'

And post somewhere logs when it is not working, in best case together with the following files?

/tmp/kresd/data.mdb /tmp/kresd/lock.mdb

The best place for it would be knot-resolver issue:

1 Like

Přesně na tento problém jsem narazil taky. Nejdříve jsem to řešil restartem routeru, pak jsem zjistil, že pouhé spuštění toho testu na záložce DNS rozchodí google na 30min taky, ale pak už mě to nebavilo a vyřešil jsem to zapnutím forwardování a oželením DNSSEC.
ISP: UPC (lokalita Litoměřice)

I’ll try that as I have a lot of problems although not wih google but many other sites.

The debugging was already enabled and the data.mdb is 20MB in size. Can I delete it and begin clean?

I don’t think it’s really Google-specific. A different issue has probably the same root causes.

Yeah I get the SERVFAIL for all non working sites.

And for me the idea of cynerd did not help.

@davey: that’s very strange. Did you see the edit he did ~1h ago?