PPTP not working?

(Disclaimer: I am very aware that PPTP is not secure. Unfortunately I’m forced to use it due to circumstances beyond my control.)

I currently have a WDR-4900 router running OpenWRT Chaos Calmer that my new Omnia will end up replacing once I replicate all the configuration from my current router. I have installed the necessary packages and configured the PPTP client exactly as I did on my current router (the configuration files look identical), however when I press “connect” on Luci (or use ifup in the command line) absolutely nothing happens. No errors, no information whatsoever in the logs (I have set all log levels to debug). There’s no indication of PPP trying to start the connection nor any other log message from any other process.

My Omnia is fully up-to-date as of today. I have double-checked all config and made sure the daemons are running. From what I can determine everything is set-up exactly as it is in OpenWRT. I’m at a loss to explain what’s going on.

Is anybody else experiencing the same thing? Should I expect any replies from CZ.NIC in this forum or should I create an issue at GitLab?

I’m just trying to setup PPTP client as a new interface on my Omnia and I so far it looks like you are describing. Interface gets added via LuCI but is “dead”. Absolutely no signs that pptp client tried to connect and create the tunnel.

I was roughly following these steps:

ifconfig in the router does not show any ppp, ppp0 or pptp interface. Looking at config files in /etc/ppp hints that the config files were not generated at all. For example chap-secrets is empty.

So it looks like pppd is broken somehow.

I have followed manual configuration steps beginnig in section “Oldwiki: PPTP Client”:

Also this matches http://pptpclient.sourceforge.net/howto-debian.phtml, which works on a test Debian machine in my LAN.

When I try to pppd call mytunnel updetach or pppd call mytunnel debug dump nodetach it is absolutely silent. No response, no logs. If I type pppd and enter in my ssh session, it starts spitting some binary output.


I take my words back. I used LuCI to inspect system logs and the ordering there is wrong. Actually the command is logging everything into syslog.

Another update. Setup via LuCI seems to be working properly. Two observations:

  1. unfortunately LuCI gives no feedback when things go wrong (failed auth in my case)
  2. LuCI updates /etc/config/network, and that in turn is somehow used to configure ppp (pptp), parameters like username and password are passed via command-line so they don’t appear in some generated config files under /etc/ppp (as I expected earlier today)
  3. config files under /etc/ppp are effective, but some options could be overwritten by command-line, but you can still set options like “debug” or “dump” because those are not provided via command-line

My problem is authentification. Documentation from my provider clearly states that they use PAP auth, but my client receives rcvd [LCP ConfReq id=0x1 <auth chap MS-v2> <mru 1460> <magic 0xbf74a46f>] and then is challenged to response using MS-CHAP, which fails. This looks to me like a misconfiguration of PPTP server at my provider.

Conclusion: at this point it looks like there is no fault in Turris or OpenWrt (except for poor LuCI presentation in case of issues)

My problem is solved. PPTP interface is up and running.

I had to add these into my pppd options:


And also comment-out mppe required,no40,no56,stateless (my ISP does not support mppe)

I was away and did not play with the router since November. Now that I got back I updated it to the latest version (3.5.3) and PPTP is working, so whatever problem it was fixed back then it got fixed in newer releases.