PPPoE: PAP authentication failed (Turris MOX)

,

Hello everybody, I would appreciate help in setting up connection on DSL. Turris MOX is behind Terminator (provided by ISP CEZNET), with VLAN 848. Connection is established but always terminated with error AUTH_TOPEER_FAILED (as seen in LuCI Interfaces).
System logs shows error as Remote message: Login incorrectPAP authentication failedConnection terminated

According to ISP technical helpline MAC address is set correct, username/password as well.

Full system logs:

May 14 15:50:54 turris pppd[21996]: Plugin rp-pppoe.so loaded.
May 14 15:50:54 turris pppd[21996]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.8
May 14 15:50:54 turris pppd[21996]: pppd 2.4.8 started by root, uid 0
May 14 15:50:54 turris pppd[21996]: PPP session is 1
May 14 15:50:54 turris pppd[21996]: Connected to e4:EDITED:34 via interface eth0.848
May 14 17:50:54 turris kernel: [ 936.894172] pppoe-WAN_CEZNE: renamed from ppp0
May 14 15:50:54 turris pppd[21996]: Renamed interface ppp0 to pppoe-WAN_CEZNET
May 14 15:50:54 turris pppd[21996]: Using interface pppoe-WAN_CEZNET
May 14 15:50:54 turris pppd[21996]: Connect: pppoe-WAN_CEZNET ↔ eth0.848
May 14 15:50:58 turris pppd[21996]: Remote message: Login incorrect
May 14 15:50:58 turris pppd[21996]: PAP authentication failed
May 14 15:50:58 turris pppd[21996]: Connection terminated.
May 14 15:50:58 turris pppd[21996]: Sent PADT
May 14 15:50:58 turris pppd[21996]: Exit.

System:

Model: CZ.NIC Turris Mox Board
Architecture: ARMv8 Processor rev 4
Target Platform: mvebu/cortexa53
Firmware Version: TurrisOS 6.0-alpha2 b93327c4692e605649ff1afade98899a9c4aa1ca / LuCI branch git-22.213.35964-87836ca
Kernel Version: 5.15.59